Maslow Home Maslow Community Garden Newsletter

Sled doesn't jog, "Message: Unable to find valid machine position for chain lengths"

Hi,

I’m connecting to my M2 and trying to follow the calibration steps. When I open the connection, I see the beginning of the correct Grbl Gcode readout followed by a many times repeating error code “Message: Unable to find valid machine position for chain lengths 1532.86, 1532.83”
I can’t type anything into the console after that.

Why this is a problem is in the calibration it says to type $83 = chain length but I am not able to type anything.

I am not able to jog. When I click move in any direction it just keeps moving up, step by step, and won’t stop unless I hit reset.

I did reflash the arduino due with the latest firmware from the M2 resources page and I’m using Makerverse 1.0.6.

image
here is the screen shot. This message is just constant so I can’t update anything. I think I need to update the scaling which was way off, like 1,000 mm. But I can’t type $85 or $86 = anything. Nothing takes in the console.

Shouldn’t reflashing the arduino erase the settings? Below is the screen shot of the scaling that doesn’t change even if I re-upload the arduino m2 firmware.

I used the “calibrate” button and just entered in the same value to expected and actual and the console shows writing the gcode but the scaling is still insanely large, 1400ish

image

@MacAleese do you have any thoughts?

Sorry, this messaging system on here confuses me sometimes. What was the question??

In the forum post? It’s pretty long with screen shots and things, but you should just be able to scroll up to see it all.

I think this was the guy I directed to speak to Mike Garza in the Facebook group. But I’ll have to check for sure later. Not home right now

1 Like

Hi Guys, any idea on troubleshooting steps? This is a perpetual error at this point.

Any help is greatly appreciated!

reset the eeprom and then reset the chains and recalibrate. If you flashed the arduino, you might have a corrupt memory spot and that should fix it… or possibly could fix it. Worth a shot and only about 30 minutes to get it going if it works.

1 Like

I have a feeling that this will do the trick.

Basically your machine has an impossible setting like that the motors are a negative distance apart or something and as a result it can’t solve the equations to figure out where it actually is.

Hi Orob, Bar,

I did mention in the post that I have reflashed the arduino about 5 times and that is not changing anything. Shouldn’t reflashing reset everything such as the scaling? This link was the thread where you helped me troubleshoot the reflashing. In the end we got it. But after sending the firmware onto the arduino it didn’t seem like anything changed

or maybe I am misunderstanding the suggestion. What do you mean by reset the eeprom?

So this is what you mean by reset the eeprom? Use the Arduino IDE?

2 Likes

Resetting the eeprom wipes all settings and is not the same as flashing the firmware. In makerverse in the calibration screen there is a button for it or you can type that command in the terminal window to reset.

1 Like

It’s a bit confusing, but the distinction is that the firmware is the software the machine is using to run, while the eeprom is the place where the machine stores it’s settings like the distance between the motors.

Hi, it’s still not working. first of all, I still can’t type in the console because it keeps constantly looping a print of “Message: Unable to find valid machine position.” So I made a custom button to send the command >$RST=* which you can see in the screenshot didn’t change anything. I also couldn’t find in the calibration menu where there is a button for eeprom reset? But anyway you can see in the console that the command didn’t change anything. Anything to try next?

Actually, I just thought maybe I shouldn’t type the carrot and it actually stopped giving the error message!! now we will try to re-calibrate.

Okay wow, it’s finally working. Thank you all!!

I was going to tell you to not type the >, but it looks like you figured that part out. Glad you got going.