Re-setting home position and updates for WebControl?

I have not messed with my Maslow since I got it up and READY to run…never really made a project. I actually have a couple questions:

  1. In the past year, you genius’s have most likely upgraded WebControl. Will my link from last April bring up the version from last April or will it bring up the latest? If not, what do I have to do to get the latest version?
  2. I just re-learned Easel and drew up plans to cut out 2 corn hole games for gifts. The 6" hole was the reason for using the Maslow, anyone can cut a board in half 2 ways. Anyways, the Easel program uses the lower left corner of the sheet as 0X,0Y but when I import the G-code to WebControl, it puts home at 48X, 24Y. I’m NOT connected to the maslow but trying to move the home. I know I have done this before but can’t remember how. Is the problem that I am not connected? Do I have to manually drive the maslow to my new home in the lower left for it to work or am I doing something else wrong?

Oh, I should clarify. I am using a Raspberry Pi to run the Maslow and I log into it via my laptop. I absolutely fear having to re-load WebControl on the Pi since it has been so long since I messed with it.

Thanks for your help in advance

If your webcontrol is from last April you should be good. Current released version is .94.

You have to be connected and move sled to desired position to save home.

I believe you can set up easel (it’s been awhile) so it’s center is home. This will make it easier to position you cut on the maslow.


here is a link to a yooostoobs video on how to set the Zero (x/y) in Easel:

I haven’t used Easel in forever, partly because you couldn’t set the 0,0 anywhere but the bottom left, and it was very very basic for what I was wanting to do, but I pulled that link from a FB post that said it was a new feature. I cannot confirm the ease of doing it.


Thanks everyone. Yeah I’m pretty sure I had all this figured out last April but then life got busy and I forgot it all. . I’m hoping to cut some laundry cabinets and some built-ins using the Maslow.


So you just want to move the origin of your drawing… Not sure how to do that in easel, but you are on the right track. If you don’t figure out how to move it, you can just upload the file, drive the sled and save home until it fits on the work area. As mentioned the Webcontrol version you have should still work fine.

1 Like

Yep, it worked…until I tried to download the g-code and it said that I was using Easel Pro feature which required a subscription. Bummer. Oh well, I’ll just drive the sled to lower left and zero and all will be good. Thanks for the help.

1 Like

ever tried estlcam?

Or carbide create v6. (v7 will not work with the maslow but you can get v6)

It’s hidden but here is a link.