Maslow Home Maslow Community Garden Newsletter

Web Control, Firmware and Mega 2560 Maslow Arduino

I have been able to get WebControl working on my computer, finally (Windows 7).

I have used GC in the past, then tried to get MakerVerse to work, very unsuccessfully.

I then tried to get GC working again and it was a disaster.

My plan is to start from scratch with WebControl. I would appreciate suggestions on the proper steps for firmware install to the Arduino. Should I wipe the eprom and load the firmware from WebControl or ??

When I was trying GC last, if I tried to move the Z-Axis, the sled moved instead. Very wierd!

Thanks for the help.

Yes, it is best to flash the Arduino from WebControl to make sure you are on the
right firmware version for compatibility.

David Lang

do you have an easbay system? those newer boards are different and don’t do the standard firmware… see a similar thread here with a similar issue IF you have an EBS system.

As long as you can connect to the board from WebControl, there is no need to use Arduino to change the firmware?

Is it possible for the board to have some phantom bits even after using the eprom clearing function?

Thanks.

webcontrol ships with a copy of precompiled firmware so if you want to use the holey calibration method, you can simply have webcontrol rewrite your fimrware *flash" your mega board. The Arduino development environment uses AVRdude to flash the arduino mega. Webcontrol uses AVRdude to flash the arduino mega. The difference is you can only used the hex file in the webcontrol folder if you do it with webcontrol, but you can pull a newer version from github, compile it and flash it with the arduino IDE or even change it and do whatever you want with the code… except sell it. Some have posted issues with reflash and have solved them by wiping the eeprom memory, but generally that is rare, so should not be a major concern. More recently I’ve seen motors go crazy because the shield is an easbay shield and the webcontrol hex files don’t play nice yet with those. I hope to fix that soon and get the github version up to date and put out a 51.29 version code base so that hex file can be included with webcontrol.

Thanks for the explanation. I purchased by system directly from Maslow and I am pretty sure I do not have the Eastbay board (I am 20 miles away from the machine).

Thanks so much for the detailed explanation and all your hard work on this.

1 Like

Is there any problem with flashing right away to the 51.29 Holey version as part of a wipe and firmware install?

51.29 is an alpha release and needs to be tested. If you want to test, you can certainly use it.

I am sorry. I meant 51.27 included with WebControl. I want to take advantage of the Holey calibration.

webcontrol will flash it for you. good option.

1 Like

I am almost there!! I have been able to get WebControl working on my ancient Win7 laptop, wiped the eprom, installed the Holey firmware (in WebControl), entered the appropriate data in the “Quick Configure” window and marked and measured the chains using “Set Sprockets and Chains.”

Instead of proceeding to the Holey calibration, I just wanted to do a simple test cut. I loaded a g-code file and pressed “Play.” The sled proceeded to the cut start and stopped.
An error something to the effect of “Sled Cannot Keep Up” (sorry if this is a bit wrong - I am miles from my machine).

I saw this post: Feature Request: SNKU Warning and Alarm about a setting change.

Am I correct the setting for Position Error Limit under Advanced Settings should be set to 20 (instead of 2)? Any other suggestions would greatly be appreciated.

2 is too low, 20 only errors for me when the power cable or vacuum hose catches on something. And it has to really catch.

Do you think this was the issue? The default setting at 2 caused the sled to stop?

Any other potential causes?

Another question: What are the steps to get the sled moving again if it stops/pauses?

not being calibrated, various other issues could happen, but the sled not
keeping up error is only triggered by violating this limit. It’s well known that
the default of 2 is too sensitive when combined with high feed rates. This
feature really needs to be disabled until we get acceleration planning
implemented.

David Lang

Still having issues with my Maslow. These are the steps I performed:

  1. Got WebControl working on my Windows laptop.
  2. Connected to Arduino board (Mega 2560 from original Maslow kit) and wiped the eprom.
  3. Loaded the Holey firmware using the link in WebControl successfully. So far, so good.
  4. Entered the basic configuration measurements using Actions->Quick Configure.
  5. Measured and marked the chains using Actions->Set Sprockets and Chains
  6. Moved sled to the center using Actions->Return to Center
  7. Looking good!! Using the controls, I moved the sled to various parts of my panel and it worked great! I was feeling good about how things were going so I returned the sled to center and loaded a simple circle g-code file to cut.
  8. After pushing Play, the sled started to progress to the start point and stalled (Error: Sled cannot keep up). I returned to center and shut it down.
  9. After a forum posting and response, I set the Position Error Limit to 20 and tried again.
  10. Same error of sled being unable to keep up when trying to run the g-code.
  11. I returned to center and tried to run the Holey Calibration. The sled starts to move to the first mark and stalls with the same “sled cannot keep up error.”
  12. Now I have another anomaly: When I click on the “sled move right” arrow, the sled proceeds at an angle to upper right. Clicking on the “sled move left” arrow moves the sled at an angle to the lower left. I shut everything down for further troubleshooting, with heavy emphasis on trouble.

I am flustered as to what the issue is. I am wondering if there is any phantom content on the Arduino board. My troubles all started when I tried to get MakerVerse running after successfully using GroundControl. I just wanted better calibration and feel WebControl is the best answer. Any input is greatly appreciated.

I think this is the core issue that we need to fix first. If you are seeing this issue consistently it means that something is off. Could one of the connectors to the motors be loose? It might be worth unplugging both ends and replugging them.

Maybe the power supply is having trouble keeping up?

What do you see when you run the Test Motors /Encoders function?

You had ground control working? Did you import the .in file? Sounds like your 12 v power supply may be struggling.

I had GroundControl working just fine. However, I could never get the calibration to dial-in. Then I tried getting MakerVerse to work, without success. Using MakerVerse gave me the first odd control/motor behavior on the sled motion and Z-axis.

I am sure my ground control.ini is messed up and that is why I did not import using the WebControl option. Between going from MakerVerse and trying to get WebControl working, I installed a 12’ beam. My initial config of WebControl (with the change in motor distance, etc.) seemed to work fine.

How can I find the specs for the power supply? I might have one around somewhere.

It is just a 12 volt supply, but I believe it is rated at higher amps than you typically find.

Edit - ADD -> If you had a computer power supply, those put out plenty of 12V power. Just use the yellow and black wire. You will likely have to ground the green wire to a black wire get it to turn on though.

I will try to find a different power supply. This may be the cause of the “sled cannot keep up.”

However, what might be causing the wrong direction movement of the sled when using the WebControl sled movement arrows?