Trouble with first cut

I’m a total noob here - just set up my M2 and created a very simple shape in Easel like this:

Very basic. I’m cutting half-inch plywood. The goal was two circles - one that’s ~1/8" deep, the other that’s 1/2" deep to cut all the way through.

Exported the gcode from Easel, and imported it into Makerverse, which showed this:

Screen Shot 2023-01-15 at 11.28.56 AM

Hit the play button to start cutting. For some reason, Makerverse told the router to cut on it’s way to the circles, and then backed off the z-axis so that the router bit was hovering above the surface when it was supposed to be cutting. So this is what I was left with:

So it’s cutting when it’s supposed to be just repositioning and not cutting when it’s supposed to be. Any ideas?

Perhaps relatedly, when I click the return to home button, it extends the z axis ~7mm so the router bit drags across the surface. Not sure why it doesn’t consider 0 to be home on the z axis.

Sounds like your z axis pitch is backwards or your gcode thinks the home position is inverted. When you made the gcode did you post process with grbl and tell it the top of the workpiece is zero and the z moves negative to plunge?

1 Like

Thanks but I don’t know what grbl is, so no, I didn’t post process. Is that a usual step? I thought you could just export a .nc file (which I guess is gcode) from Easel and import into makerverse and then cut.

Is there a good video tutorial on this? I see lots of videos on setup, calibration and one on makerverse but that one doesn’t walk you cutting a project.

Was the z axis acting correctly during the calibration?

post processor is something you select in your settings and then the gcode is formatted correctly for that system. GRBL is the gcode dialect we use. Our systems are “mostly” grbl compliant, so GRBL is the post processor used. It is not critical that you know what it means at this point. Like Tim said, if your system did the calibration correct, then the generation of the gcode is the issue. There should be a setting for where the origin is and whether the cutting is positive or negative from the home position.

The manual says you can skip Z-axis calibration, so that’s what I did when I set it up.

Now I just clicked the “invert z axis” checkbox in calibration and it seems to be moving in the right direction. I cut a test circle and now the issue is that it cut way too deep - all the way through the waste board. When I test the movement, it seems to be off by a factor of 2. I could input this data into the z-axis calibration, but I’m not sure about the accuracy of my measurement. I’m just using a ruler - I don’t have calipers. Any thoughts? I’m surprised about the inversion and lack of accuracy on this out of the box.

Also something weird while cutting that I noticed: Between passes, it jogs the router up a couple inches away from the material and then back down before resuming cutting. Is that normal? Seems like a big waste of movement and therefore time to complete cutting.

I’m not too keen on makerverse but the maslow is doing what it’s told to do. The pitch setting is likely off since your plunge is too deep according to the gcode. The travel height is determined by program settings (I don’t know where in makerverse) and via gcode.

I can’t help much more than that, I use webcontrol to control my maslow and carbide create to create my gcode.

Here is the maths for fine tuning your z pitch. (Taking from the meticulous z axis post)

To calculate the movement error:

E = D2 / D1


E = Error

D2 = Distance the carriage actually moved D

1 = Distance the carriage was requested to move

To calculate the corrected setting:

C = Z * E


C = Corrected Z-Axis mm/rev

Z = Z-Axis mm/rev from the test

E = Error

Thanks for the help @TimS and @Orob - I’m hoping there’s a simple solution here, and also want to figure out why there’s so much excess movement in the z axis between passes, so I think I’ll take this topic over to MakerMade and see if they can figure it out.

the z excess movement is likely your gcode. is the bit doing one pass then moving up and then back down deeper for the next pass? I had code that would do that… it was like watching paint dry to cut something out. I switched to estlcam and that helped a great deal.

Agree with Orob. It’s likely in your gcode.

Probably a setup option for travel height in whatever program you use to create the gcode.

As @Orob and @TimS have stated, the excess movement in your passes is set by your “safe height” and settings in Easel and translated into your GCode. You should be able to lower your “safe height” so it doesn’t have to move so high. This is also related to getting you Z-pitch corrected/tuned so it is moving the correct distance. If this is off (based on you stating it went too deep in your test cut), then not only will it move too far down in your cutting, but it will also move too far up in the travel moves.

As @Orob stated, I think Easel automatically puts in a return to “safe height” between all of it’s passes, even if it is cutting a simple pocket (which is what you showed in your original post. So it will do the first pass and cut the circle, then will raise up to safe height, then lower again to the new depth and cut the next pass, etc. etc., even though it doesn’t need to as it is not moving to a new location. Some programs have a setting which will allow you to remove those types of moves if it is staying in the same location. I am not sure if easel will let you has I used it a few times and then move to Carbide Create. The free version let me do more than the free version of Easel. If you make the move to CC, make sure you don’t use the latest version (I am currently using v5 IIRC) as it will not let you use all the capabilities. I know someone here has posted what version to look for, but I can seem to find it.

1 Like

@TimS Thanks! I knew someone had posted recently about it!!

Thanks for the suggestions everyone!
I looked at Easel and the safety height is set to .15". The amount it’s traveling between passes is more like 2-3", so it seems that safety height maybe isn’t the culprit. It’s also not doing this in between every pass - it will cut a couple passes, then move out 2-3", then move back and continue cutting. Not sure what to make of that, but I will try using Carbide Create to make the gcode and see if I have better luck with that. Thanks!

Can you check if makerverse has a travel height setting?

Also, if you post your gcode, (nc file) we can look at it and make sure it’s not in the gcode.

Can you send a pic of your sled setup and what your z pitch setting is?

Thanks @TimS but switching to Carbide Create seems to have fixed the problem.


Good to hear! It’s a good program and not too difficult to learn.