Retract all doesn't

My setup:

newly assembled kit - latest firmware.
12’x8’ portrait oriented frame basic frame design. I will slope this at 15% in my garage.

I did the retract all, then extend all. some of the belts seem shorter than others at this point, but all are responding…

Then I went to retract all again and nothing happened. after restart, I got one of the belts to retract, but none of the others did. I rebooted again and tried retract all and see this in the output (nothing retracted):

[MSG:INFO: Retracting all belts]
[MSG:INFO: 3 pulled tight with offset 0.000]
[MSG:INFO: 2 pulled tight with offset 0.000]
[MSG:INFO: 0 pulled tight with offset -0.011]
[MSG:INFO: 1 pulled tight with offset -0.666]


1 Like

This sounds totally normal. The lower two belts will be slightly longer to give extra slack to make it easier to hook things up.

You aren’t the first person to run into this so we added a setting for it. This is the setting that you want to change in your .yaml file:

I would try increasing that value to say 1500 and see if that fixes the issue.

Sorry about having to edit the .yaml file directly. I know it’s a hassle, we’re working on making editing the settings more user friendly.

Yep, hope to help. In any case, that did get one more belt to retract and the remaining two stayed right where they were. I rebooted and now none retract. is there a way to send commands to get a specific belt to run this retraction routine?

Are all four belts still hanging out a bit, like there is some floppy part still showing?

What happens if you press Extend All and pull on one after pressing Retract All

two are all the way out. they did not budge on retract all. one is hanging out a little bit, one retracted all the way to the opening. I’ll try extending again, then retracting… one minute

1 Like

OK, so when I extend all, I had to pull on each belt to get it to extend. when I stopped pulling (lightly) it would stop extending. I did this for all 4 belts and they all extended with that coaxing.

Then I hit retract all. 3 of the 4 belts (the second from the top didn’t move) started retracting and forcefully stopped at the openings. the fourth belt second from the top did not move, even with coaxing (pushing in and pulling out on the belt…).

This is totally normal. That is 100% how it should work. Because we can’t really “push” on a belt (it’s floppy) they will only extend as long as you are pulling.

Great, that sounds like progress.

What do you have this set to? Is it at 1500? If it is let’s try 1700 and see if that fixes the one that is still sticking.

will do. is there some point at which it is too much stress on the clip? Did I maybe tighten things too much on the spool?

1 Like

Probably, but I don’t think we’re there yet. I changed the default to 1800 before it was a setting a few versions back and that fixed the issue for a lot of folks and didn’t break anything.

yea, 1700 did not cause anything to happen on that last belt. I’ll try 1800

1 Like

It might be worth extending that one all the way out using Retract All (it won’t move) → Extend All). Maybe something further back in that spool is jammed up?

yea, 1800 didn’t work either.

I did try pulling it all the way out and retract just does nothing on that spool at all. seems to not even start to retract.

1 Like

OK, that’s pretty weird. This sounds like maybe there is something funky about that arm.

Can we try plugging that motor into a different port on the controller board just to confirm that it won’t work on the other port either?

OK… still not 100% how,. but after several rounds of extend/extract jiggering the belt around on that… it finally did retract. I did also unplug and re-plug the ethernet connector for that one.going to go back to 1500 or so and try again.