Maslow Home Maslow Community Garden Newsletter

Ripped in half sled out of control when attempting z access ajustment

I was calibrating in Makerverse and the machine went on its own, up until it pulled itself apart at the track.

now I need a new ring and sled.

how do I calibrate the machine when I try to adjust the z and the sled moves up uncontrollably?

I checked wire connections, I have slack and there tied off

will not cut the correct size of file.
will not calobrate
software is malfunctioning
and I don’t know if there something boring with board on the unit

when you do a motor test, do the right motors move in the right direction?

are you sure you have the right firmware on the controller?

David Lang

firmware is up to date,
now it just runs out of control, when I try to make the slightest move in the calibration setting or on the main screen in any direction and I have to pull the plug to stop it

if it doesn’t know where you are, it can’t move sanely.

the first step is to find the motors test and make sure the motors turn
correctly.

after that you will need to reset the chains to a known position (or start
calibration from scratch) before you have any chance of moving where you intend.

David Lang

it moves just fine and then it just starts going on its own and docent stop you didn’t address anything I said

firmware is up to date,
now it just runs out of control, when I try to make the slightest move in the calibration setting or on the main screen in any direction and I have to pull the plug to stop it

did you do the motor test to make sure that the maslow can control the motors
properly? until you do that test, anything else is meaningless (it may be that
there is a problem with an encoder, or the encoder connection to the controller,
if that’s the case, it’s not possible to do controlled movement and that needs
to be fixed before you try anything else)

David Lang

this same problem happened to us…heartbreaking and unbelievably frustrating

we strongly recommend that a motor & chains test process be created in the M2 CNC setup documentation + video have a motor test before sled is attached because this is a common problem. In our case the destruction from runaway sled was because nothing was calibrated…we were so excited to assemble the whole machine that we did not test the motors and chains…BUT there was no obvious warning that we needed to STOP and check chains and motor setup BEFORE adding the sled…Mr David Lang is absolutely correct that a motor + chains test is SUPER CRITICAL before before before before before before before adding the sled…this was a very expensive mistake on our part :frowning:

We take FULL responsibility for destroying our M2 CNC sled because we didn’t STOP and test motors + chains before adding the sled…that is a BAD MOVE…we absolutely agree with Mr. David Lang (who is one of the awesome experts here) that fully testing the motors + chains BEFORE adding the sled is critical…we got so excited to finish assembling the machine and seeing it move around that we neglected this critical step. The M2 CNC will go absolutely bonkers if the machine is not calibrated and/or if any cables to the motors are loose. We have made ALL of these mistakes and had to pay the price by rebuilding the machine. Lessons learned (the hard way)…please learn from our mistakes and test the motors + chains BEFORE connecting the sled…we do think that an updated assembly video that highlights the CRITICAL need to STOP and test the motors + chains BEFORE attaching the sled with a STRONG WARNING be created by Makermade…We also think a big physical red button emergency stop button should be added to this machine somewhere such as what we see some other experts have added to their machine setups. I would love to see an upgrade kit be offered by Makermade in the marketplace that includes all of the 2Tankards dust collection and sled calibration jig products AND a big red emergency STOP button that can easily be wired into the machine’s cabling and attached to the frame…we plan on buying many more M2 CNC machines and absolutely will build future machines using these products (we highly recommend these upgrades)

PS, Makermade was really friendly and helpful to us in getting replacement parts after we destroyed our sled, thank you Mr. Joel and team! We hope Makermade becomes a hugely successful company someday that can afford to hire more people to help newbie customers like us and others. This is a complicated product to build and assemble but WOW it is awesome once finished





2 Likes

unbelievably frustrating due to no up to date info on the new software and a collate lack of actual customer support.

your asking me to test something before. I mounted the sled and I did, problem happened in the middle of calibration . I did sucesfully test the motors and chains and the z …

this mistake is due to a software glitch for a problem with the board, how could it be user error when it just goes on its own out of control. during the sled calibration process!!!
not my fault, software is unresponsive tried installing and reinstalling,
as perversely stated I tried to move the z and went still it bottomed out and the lead screw popped out then it went off on the z access until it pulled apart.

yes and yes. it happened I the middle of calibration.

You sound super frustrated and based on what happened It sounds justified. Perhaps makermade, who sold you the kit, might have some remedy for you. This is the free users group.

The M2 uses a different controller than most of us use. Before you calibrate or do anything, you have to set home or reset chains depending on which firmware you are running. Once you do that, then if you are using an M2, you will want to have a power strip with an easily located power toggle that connects to the controller power supply so you can cut power to the motors should the system start doing its own thing. I’ve had this happen when trying to calibrate the z axis before setting home or resetting chains and one of the reasons I use the older mega controller.

2 Likes