Strange Movements

I don’t know what has happened, but my M2 is making a different sound while moving, and I get extra movements when jogging the machine.

Everything has been working fine for months. I was working on a simple cut last night and making some adjustments to my feed rate and speeds by creating manual cut settings in Easel and then outputting a file to cut in Makerverse. I cut the same piece three times trying to optimize things, and suddenly in the middle of a cut, it took off on me and started travelling somewhere it shouldn’t. I stopped the job and reset the board, and then tried to home (work zero), at which point I could see that my Z-axis had changed and +5 was now zero and dragging on the piece. I recalibrated Z-zero, but work zero was now different (and not the location where I zeroed the Z).

All of my position and calibrations were out to lunch. Z at +5 was at zero, and work home was up and to the right by 150+mm. I recalibrated Z and attempted to reset work zero, and then I need to jog around the work to make sure that it lines up properly and it does not.

What is really confusing is that if I move more than 100mm, I get extra movements. Like, go up 100mm and it will go up 100 or more, and then I get an extra jerk movement of 15-20mm up and to the right, and then back down 5 or so. Sometimes I can tell it to go 100mm and it will just keep going until I hit Pause and then have to reset the board connection. Horizontal movements of 500mm left or right both go down and when it reaches 500mm it goes up diagonally like a hockey stick.

If I try to calibrate my edges, it is way off. Center is high by 300+mm, although good from left to right. When I tell it to go to the top right or bottom right corner, it goes way past. I can’t calibrate it with any sort of accuracy this way, and the calibration screen does not have a pause or stop button, so the only way to stop it when it gets out of control is to unplug the USB port.

I have checked all of my wiring connections and everything is seated properly. I have cleaned and reseated both ends of the USB cable. I have unplugged power to the Arduino box for several minutes, and done a cold boot on the laptop (full power off restart), and it is still doing funky stuff.

It’s not consistent either. Sometimes it will move 100mm (with an extra jerky twitch at the end), and sometimes it will just travel some crazy amount (400+) and I have to pause and reset.

I don’t know what has happened. I haven’t had a power surge or anything, and it was cutting fine without any problems, just all of a sudden things went wonky. Luckily I was right here and stopped it before it could do any damage, but what could have happened and what can I do about it?

Well, I am trying to do some troubleshooting and figure things out on my own.

I attempted to do edge calibrations and let it go so that I could at least get some rough measurements that I could try to improve upon. Things went badly. At the right side of the wasteboard, the sled went well past the edge until there was no chain left, and it literally tore the nail out of the end of the chain on the header board and it came apart. I was fortunate that the sled wedged itself into my drum sander bench, so that stopped it from crashing onto the floor.

The left side chain tore out, and it came apart. A picture of sadness.


At this point, I had to take my own advice - STOP and think… Of course, it would have been better to stop prior to this point, so I can kick myself for that, but here I am.

So I stopped to have a beer and think. If my work zero and z-zero positions have the same settings, but the sled represents something different, something is wrong. All of this jerky movement and continued motions and strange stuff has to come from somewhere. I have worked with computers and electronics for many years, and behavior like this tends to come from communication issues or a failure of a component. Now that could mean a lot of things. There are lots of tiny wires and a couple of circuit boards. Time to start tracing things out and establishing what I do know.

The primary point of communication between my laptop and the machine is the USB cable. It is a 20 foot cable that goes from the Arduino box over to my fan chains, and then along the side of my workbench and up to my laptop. 20 feet is a long cable, and although I have not had any issues with it in the past, the winter weather is much dryer (more static) and it certainly has potential to get pinched or kinked. So I purchased a new USB cable (10 feet was all I could find, but it would work), and when I swapped out the cable, I noticed that the input on the Arduino board moved. It appears that the solder points that hold the USB port onto the board have broken, and it doesn’t hold the cable solid like it should. This would appear to be the problem.

In taking the Arduino box apart, I see that it has a second USB port, but the 3d printed case keeps that port covered. Is it possible to use the other USB port?

I am going to see if I can solder it up again, and I will post up to say how things work out.

1 Like

Don’t have any insights or advice to share, but I just wanted to wish you luck figuring it out and rebuilding.

1 Like
  1. are you using a 12’ beam? If not, your beam is a bit high and your chain may not be long enough. What is the distance between your spoil board and the motor shaft plane? (see here)

  2. The Due has 2 ports on it. One is the program port and one is the connection port. Only one of them will work, but the firmware version you are using with determine which is the correct one. One issue with removing the controller from the case is that the due controller shield has fewer pins, so they tend to separate if not held together firmly with the case. Some shields have separated slightly and that causes weird behavior as the shield with the movement chips don’t communicate correctly.

  3. When the initial M2 came out, there were a few users I tried to help who ended up with bad Due boards. Makermade covered them as far as I know and that fixed it. I don’t know that the root cause of the controller problem was ever shared, but the tell-tale sign of trouble was the communication terminal would show random garbage characters and sometimes makerverse would not “detect” the controller attached. There has been speculation that the eeprom was corrupted somehow. You might try wiping the controller, clearing the eeprom with the erase command has helped at times and at other times, replacing the Due has helped. The erase command is on this forum somewhere. You’ll have to search. It is a terminal command you type in makerverse (starts with $) and it resets all the memory. You could also delete your .makerverse file (which will erase the “machine” in makerverse and you would need to start over. Either one of these will require reconfigure and recalibration.

  4. 20’ usb without an active amplifier is likely to be a problem, but may not be the issue. The not-so-quick fix is the 1’ cable and a raspberry pi. The 10’ cable should be better, but a 6’ would be certifiable. Certified USB cables are 6’ or less. The USB logo is only allowed to be used with components that have been tested and certified by the USB working group. If in doubt, look for that trademarked logo, not just the text specifying USB for cables and devices that are mission critical.

  5. I installed a light switch on my maslow that switches an outlet that is connected to the shield power. This allows a quick switch toggle to stop the sled movement, but not kill the software, so it can be recovered. Webcontrol actually stops the movement and cancels the rest, but Makerverse will try to continue the move when you turn the sled movement motors back on. Something to be aware of.

I hope some of this is helpful.

Thank you @Orob for the detailed response. I greatly appreciate the help!

I have repaired the USB port, but the same problem remains. I have yet to try to recalibrate things, but I will once I set up a power bar as I will mention again below.

To answer your questions:

  1. I am using a 10’ beam. My measurement from the top of the wasteboard to the top of the beam is 15-3/4", which makes the Y-offset to the center of the motor sprocket is 18" from the wasteboard.

  2. I can see by the markings on the Due board that I have been plugged into the program port, and the unused port is marked as communication, which is why I asked if I can use it. I have had the case apart and the two boards separated in order to repair the usb port, and I noticed when putting it back together that it doesn’t use all of the pins (doesn’t line up with the ends). I believe I have it put back together properly, and it is behaving the same way as it was, so I believe it is correct.

  3. I have held off on wiping and resetting everything, but even after repairing the USB, the behavior is the same. This may indeed be the next step.

  4. I agree that 20’ is quite long for a USB cable, and I get the same results with a 10’ cable. I will try to reconfigure things to test with a 6’ cable, but it can’t stay that way. I’m not sure that the USB cable is the issue, because the issues are consistent and repeatable. I am leaning more toward a problem with the Due board.

  5. I like the suggestion of a switch. I will add a power bar with a rocker switch that I can use to cut power to the Arduino.

I will post back up after I try a few things.

Cheers, and thank you again!

1 Like

Alright, well I have my other stuff done and now I am trying to get back onto figuring out what is going on with my M2, and it is frustrating me. As mentioned above, I have repaired the USB port, and replaced the USB cable with the same results. I still get little extra jerks at the end of movements, and hockey stick hooks at the end of larger movements. Any movements horizontal or vertical are not straight. My center WAS low and left, and now it appears to be beyond the bottom left corner, so I am stuck on trying to do anything. I cannot calibrate when the range of movement is well beyond the chain length. I am trying to move the sled manually to the center of the frame, but the soft limits will not allow me to get there. Everything is way off, and now I can’t find the instructions so that I can wipe everything and start again from scratch. Where can I find the manual for this thing?

This sounds to me a bit like the sled not being able to keep up with the speed that it’s being commanded to move. Do you see the same behavior if you set it to move really slowly?

That’s a question for MakerMade, but they should have one on their website

If your calibration is wrong, the machine isn’t where it thinks it is, and you
have no chance of the cutting being straight.

you need to figure out a way to go through the calibration routine before you
have a chance of making it work

David Lang

bar: I downloaded UGS because I use it on my little machine, and it made movements very well at speeds up to 600mm/m (which is what I currently have the M2 settings set as a maximum speed. I did note that the vertical and horizontal movements are still not straight, which is why I am trying to calibrate in Makerverse, but no jerky or hockey stick movements in UGS.

David: I do agree that I need to recalibrate, but the machine is no where close to being able to do it. I’m looking for the documentation on how to set the chains, and I will remount the chains and sled and try again.

1 Like

Well, I tried to calibrate and wiped my settings from the button in the Calibrate screen. Here is the play-by-play, or just skip down to the end for the fail.

Maslow Calibration
Machine: I am leaving these settings the same, because I have stock chains.
Stock: Same. Width 2438.4, Height 1219.2
Frame: was Motor Heigh 463, changed to 385. Motor Width 2978.4 changed to 3117.
Sled: Standard 18-inch circle. I’m not changing this because nothing on the sled has changed.

Z-Axis: I had to Invert the movement because it was going the wrong way. This is really hard to measure. Commanded a movement of 10mm up, measured 16mm change. I cannot set the Z-Zero because it hits a soft limit. Even after resetting and unlocking, it refuses to touch the material. Still 10mm of space to the bottom of the sled. I’ll deal with this later.

Chains: -288 (left of center) and 5 (above center). I measured and marked my stock at center.
Edge: Center is left (by 288mm). Move to top right. 84mm to top, 225 to right. Back to center. Feed Rate is between 1250-1296. No jerky movements though. Move to bottom right. I’m past the edge of the footer board on the bottom by -78, and 295 to the right edge. Move to center. Still left. Move to top middle. 35 to top. Move to center. Seems to be drifting to the left, about -292 to actual center now. Move to bottom middle. Looks like it is still moving left but stayed above the footer board by 30mm. Move to center. Move to bottom left. I’m nervous. I know it is going to go over, and I decided to let it go and got ready to catch the sled. Sure enough, it pulled the right side chain nail mount out of the header board, and I’m screwed again.

The nail is bent out of shape and will have to be replaced, but it held in the sprocket and did not drop the chain. The chains stayed on the motor sprocket, so I am going to try to pin a new nail.

I really don’t want to send it to top left after this. I am going to guess what those numbers should be based on the other corners, and try to calibrate again. If I can at least set up a ‘mostly sorta’ area, I might be able to calibrate it down once I get it to stay within the wasteboard?

I don’t see anywhere in your play-by-play where you disconnect the chains from
the sled, set a sprocket to 12 o’clock, put the chains on the sprocket and feed
it out

it’s only after this that you are calibrated and can connect the sled and start
movement.

David Lang

1 Like

I have disconnected the sled and set the chains prior to today. I would like to do it again though with instructions to make sure that I did it right. Do you know where I can find those specific instructions?

Okay, I did find the instructions that I was looking for on the M2 Resources page.

I have rehung the chains about four times now, and I am much closer. At least I can run calibrations within the workspace and I’m over by 37mm, which I can work with. Multiple edge calibrations later, and I am about 21mm of accuracy. Not where I want to be ideally, but it should work to get the current work done and off the board and I can try to calibrate again.

Thanks David, I appreciate your efforts!

Keep in mind that the M2 is a MakerMade product that is based off Bar’s Maslow. Although they share similarities, the due board, firmware, control program, and calibration are all MakerMade. The forums can help but MakerMade are the experts for the M2.

1 Like

Yes, I have been confused about the whole MakerMade and Maslow stuff for a long time. I see connotations and references that indicate that there are not just differences between the machines, but that there are different companies altogether. It certainly makes things more confusing, and makes support a bit more difficult, but I am pretty good at figuring things out, and the ‘hive mind’ of the forum and the internet is a wonderful resource.

With that in mind, thank you to those that have reached out to try to help. @dlang and those who have messaged me, I greatly appreciate the efforts of the experienced users who just want to see another user do good things with these machines. Cheers!

I am back up and carving again, and most of my issues are sorted now. Seems to be doing okay, I had to change my bit as it was getting dull, but the machine is back on track and I will see if things line up properly when I am done testing with this current job.

1 Like

I’m just following up here. I was able to finish the project that I had loaded on the wasteboard (1/4" birch ply), and was successful. I had some issues with my Z-calibrations which I knew was coming from a few posts back, and when I finally got to cutting properly, it was smoking quite a bit, so I was back to troubleshooting and adjusting feed and speeds. When I finally realized that it was my bit, I changed it out and everything is good. Well, mostly.

As you can see by the top cut line, my horizontal calibration is still off. I think I am off by one cog of the chain on the right motor, so I am going to have to take it apart again. Otherwise, it looks good.

At least it is working, which was a big concern. I thought I was going to have to replace the Arduino or Due boards, and I didn’t have to.

Thanks again to those who tried to assist me. Cheers!

2 Likes