Maslow Home Maslow Community Garden Newsletter

Calibration was under 2mm then home moved

My home changed in Makerverse overnight. I was calibrated to under 2mm last night and when I came in today, the home is now 8.3" above the center of the waist board. I also can’t just tell it, it is home like I used to. Do I have to recalibrate to get home in the middle of the board?

I stated to calibrate the chains but now no matter how much I tell it to move or what direction it just raises the sled until I unplug the laptop. I am frustrated and I really home someone can help.

it lost track of where it is. you need to reset the chains (the routine to set
the sprockets to 12 o’clock and put the marked link there). I’m not sure what
the process to do this in makerverse is.

David Lang

Check your cables and your board connections. Typically we see this when one comes loose. You will need to go back to center and press the reset chains button.

Ya I checked all the connections it is still moving up. Could one of the cables failed?

Did you reset the chains? You may need to wipe the eeprom and recalibrate. Is your controller board coming unpluged from the motor shield? I’ve had that happen. I’m

I just did a wipe of the eeprom, I unplugged the controller board and plugged it back in; I plugged in and checked all wires and connections and they all look good and even if I move the Z the x and y move and do not stop until I unplug the USB.

I recall this being a connection issue in the past however should I try to flash the control board again? I just updated the firmware the other day. Besides hardware failure I am out of ideas and I have a clients project waiting.

I set up a new machine in the software and told it that it was new. I went to the Z calibration and the same thing happened with the Y and X motors when I told it to move the Z.

I just tried a different USB cable and got the same results.

Which supplier did this kit come from? It’s possible that the updated firmware doesn’t match the board. That could explain what we are seeing.

I got it from Makers Made. It’s the M2. I ordered it in August 2020. It worked for a day after I flashed the firmware while I calibrated it. I got one cut but the cut was skewed.

What is the correct firmware for this model?

The updated firmware is here: github latest download → compile in arduino IDE and flash via program port.

1 Like

Even after I flashed the controller it is still just moving the sled up even when I tell it to move the Z. This is what I get in Arduino IDE Serial Monitor:

Makers Made says they are going to send a new controller however they haven’t responded to my follow up email asking about when. I was told in December that they were going to send me longer chains and I never received them. I really hope they are able to send me the controller soon. I have a project that will go to auction for an organization that helps families that have been impacted by childhood cancer that I need to get finished.

1 Like

You can tag them with @MakerMadeCNC and maybe get a quicker response. They are here in the forums.

@MakerMadeCNC Sent me a new controller and it works now, THANK YOU MAKER MADE!

2 Likes

Did you send back the one that was faulty? If not, could you open the DUE box and see if all the pins in the shield were nested correctly in their ports, or if some were unseated? Saw this on another and want to know if we need to elevate the issue. Thanks!

1 Like

Before they sent me a new one I separated the two boards and put them back together to make sure that all the pins were nested correctly.

2 Likes