Running Maslow on an older Microsoft Surface... can it be done?

Hi All!

So my buddy and I are currently running the machine on a Macbook Pro, which works pretty well. However, keeping the computer in the dust filled shed while the machine cuts isn’t efficient (or good for our lungs). We have an older Microsoft Surface that we hope to use but we’re having trouble installing ground control. Anyone have the same issue or possibly a solution?


Hi there,

That depends mainly on the graphic chip that is in that thing. It should be capable of Opengl 2.0.
If you have the model, perhaps I can look that up.

Edit: Link how to check


I’m running on the original surface pro

Looks like they have Intel HD Graphics 4000 and that means OpenGL 2.1+ :+1:

as an option there’s this
I haven’t tested it with my Maslow, but it will open GC. I will try to remember to take it home today and test it with the maslow this weekend if I can find time.

At $10 it’s could be a good solution (assuming you can find one at a local Microcenter). There’s only one USB port, though. Has anyone tried running the Maslow from a hub?

1 Like

any luck with the winbook?

Unfortunately, no. It will run Ground Control just fine, but would not connect to the arduino. It kept cycling through “connected on com1” “connection lost”. I tried with an external powered USB hub as well, but no dice. Perhaps if I had more time to troubleshoot and more knowledge of USB protocol I could figure something out, but in the end, I have an old laptop I can dedicate to the cause.

1 Like

thanks for the update. I have a intel nuc in the garage however just on the opposite side i was planing having the maslow installed.