[SOLVED] How to update index.html.gz and maslow.yaml

This might be a silly question, but what is the process for updating the index.html.gz and the maslow.yaml files? I tried simply uploading the files in fluidNC using manage local files, but the system states that there is no free space. I also tried uploading the files as a firmware update, but that didn’t work as well.

1 Like

Make sure your computer is not unpacking the gz file on download. Mine was and it gave me that error.

I also find that deleting the html and restarting gives a new upload page asking for the missing file. You might find that one more clear.


Thanks. That worked perfectly.

My process was the following:
delete index.html.gz from fluidNC local files, upload new index.html.gz
delete maslow.yaml from fluidNC local files, upload new maslow.yaml

Finally I restarted FluidNC

1 Like

Downloaded the latest firmware and with the update I also uploaded the new yaml and index files since i learnt that is the best thing to do. But does this mean you have to run calibration again. Or, can I just fill in the old numbers in the web interface and save.
In general, what is the exact procedure for firmware updates?
I’m ok now but it might be useful to know anyway.
I’m also asking because I somehow managed to zero ALL the parameter data in the yaml file. After updating all files I checked the parameters in the interface and they defaulted. So I filled in my numbers and saved. After a soft restart all parameters were 0’s.

Absolutely you can put the numbers in. No need to re-calibrate.

I did this too! I think that there is a bug, but I haven’t managed to reproduce it. Are you able to make it happen reproducibly?