Maslow Home Maslow Community Garden

Sorftware/Firmware problems


#1

Been trying for 6 hours to get all the software down/up loaded (Arduino even took around 45 minutes to configure). I feel I’ve followed the directions explicitly yet, to no avail.

Went here as directed: http://github.com/MaslowCNC/Firmware/releases/
Upon trying to upload Firmware, I am told that no Maslow file exists.

Any help would be appreciated


#2

Let’s figure out what is going on.

Can you post a screenshot of the error message?


#3

If the error is maslow.h not found, it’s often a sign that the firmware hasn’t been unzipped / extracted / unpacked to its own folder before uploading.


#4

Thanks, Gero. That, indeed, is the error message. Now, how do I go about resolving the issue. BTW, I am using Windows 7 if that has anything to with it.


#5

Gero nailed it. Error message is: Maslow.h not found


#6

After downloading the firmware, locate the .zip file. How to extract it depends on what programs you have to 'un-zip it. Try to do a ‘right-click’ on the file and search ‘extract’ or something similar. Or a ‘double-click’ might open a program to let you unpack the content. Can’t tell if there is something default on Win7.
Not sure this helps https://www.inmotionhosting.com/support/website/file-management/zip-unzip-win7
Make sure to un-zip it to a folder under your windows username.


#7

Thanks. I’m going to go back to square one and hope this procedure will take care of the problem…One more question, however: During the Arduino process, I have noticed that the downloading of drivers takes an inordinate amount of time (up to 20 minutes). Do I need to install all of the drivers when prompted? Have another cup of coffee and I’ll let you know how it goes.


#8

The Arduino updates drivers and libraries constantly, as new micro-controller boards enter the market.
If you don’t have other Arduino projects and new boards, you should be fine without updating for Maslow.


#9

Okay. Arduino seems to have been installed correctly. Here I am:. What next?


#10

http://maslowcommunitygarden.org/Firmware.html?instructions=true


#11

Still no luck. I’m giving up for the time being. I’ll revisit this later today. Thanks for your help.


#12

It looks to me like you need to start from step 4 in the link @Gero posted above and click file and then open. Make sure you have unzipped the download first or you will see that maslow.h not found error


#13

Man, this is frustrating. I obviously am not savvy enough to unzip the file for some reason. I’ve tried about every option I know and I am still getting the same error message. Maybe if you give me a call you could work me through it.


#14

Hallalujah!!! Hallelujah!!! I finally got it to upload!!! Don’t ask me how, but I did it. Even got through the ground control setup (I think).
Thank you for your help AND your patience. I’m not a “noob” but at 70 years old, I can be a bit dense at times (just ask my wife). I look forward to working with you and getting to know the folks in this “community”. Thanks again, bar. You too, Gero.

Later,

tiara


#15

Great news! :partying_face: Keep us updated.


#16

Well, I’m back. I assembled my Maslow and was preparing to calibrate and and have found that the Adruino doesn’t seem to be connected to my computer. I have tried to connect manually to no avail. I even switched ports-----no luck there. Reboot? Same result. Even tried reloading the software…nada. All the power lights are functioning on the Arduino but no connection. Any ideas?


#17

Finally got my computer communicating with the Arduino. Don’t know what the deal was…something glitchy about the com ports. Oh well.
Now…calibration procedure was going quite well until I got to the question as to chain orientation…off
the top or bottom to the sled. I selected top (clockwise rotation). Proceding on, I placed the chain on the sprocket as directed, selected “extend left chain” and it turned CCW!! When I tried the right chain, it also turned CCW. WTH!!!
Kinda frustrated at this point, Maslowians. Anyone else had this problem, or can someone explain to me what I’m doing wrong? Thanks, in advance.


#18

I am not 100% sure I have the situation right, but I think the issue is that the left chain should already be extended from measuring the distance between the motors, so it is retracting to the target length not extending which is why it rotates the opposite direction of what you are expecting.


#19

Thanks, bar. I just misinterpreted the instructions. I got it figured out. Just out of curiosity, which seems to be the prefered chain configuration: top or bottom?


#20

I preferred the bottom technique, I think you get more sprocket teeth engaged with the chain.