Maslow Home Maslow Community Garden Newsletter

Firmware Maslow.h: No such file or directory

Everything was running at one time, but felt the need to recalibrate- then left motor went erratic so decided to reload everything, and reset cables. Having issues getting firmware back on- deleted everything and trying to follow instructions to start over… Once software is loaded, correct board and serial port #5 are preselected (as before when it worked)

Step 2: Download The Arduino IDE

Download and install the last Arduino IDE from https://www.arduino.cc/en/Main/Software. Older versions of Arduino IDE have problems with libraries when compiling the firmware, so make sure you have the latest version.

(using windows app- also tried stand alone option for windows- same error)

Step 3: Download The Latest Maslow Firmware

You can do this at http://github.com/MaslowCNC/Firmware/releases/ Click the zip file for the most recent release to download

Using source code zip file

The firmware is probably not unzipped/extracted.

Extract it and then upload the firmware from that unzipped folder.

1 Like

Nope. Unzipped.

Every time I’ve seen this issue here (it’s been a bunch) it’s because someone navigated into the compressed directory in Windows. Just make sure you navigated into the uncompressed directory.

1 Like

So the folder no longer shows the zipper so guessing it’s unzipped.

1 Like

I’ll try again. Thanks