Arduino compiling error from firmware

This is an error I get when following instructions to push the arrow in the circle:
Arduino: 1.8.5 (Windows 8), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

C:\Users\The Merry Yeoman\Desktop\Maslow CNC\cnc_ctrl_v1\cnc_ctrl_v1.ino:36:20: fatal error: Maslow.h: No such file or directory

#include “Maslow.h”


compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

I don’t know why but I am able to use ground control with this error. Not successfully as my z axis didn’t plunge therefore cutting nothing. I am sure I have to re calibrate…
My z axis worked on the 5 test cuts but when I went to cut the sled… No inny outy! I’ve also realized that I should have recorded all numbers during calibration. I thought the software was doing that but I also realized that when it says " looks good! " it doesn’t mean that it actually looks good. It means that if I think it looks good I should choose this button. Am I wrong about this? Then later I discovered numbers that would be ideal in gc Settings. This is when I realized. Also someone on a tutorial said that the 5 cuts should be within certain tolerances and I had previously thought we were recording measurements to inform the calibration process. Which is it?
I apologize that I have repeated myself from another post but I am not getting any answers and it’s obvious I have a lot of questions. I don’t know where to begin. is there more of a 90’s chat style forum option where things can be clarified in a timely manner?

Could mean you did not unzip/extract the firmware. Windows, right?
Unpack the either by looking at the top menu, or by right-click and load the firmware from the folder you created.

I have extracted all over and over.

1 Like

Can you post a screenshot of the folder that the Ardunio software is trying to open the file?
We did have the same error a couple of times here.

Here you go. and I believe i solved my z axis problem… I’mnot supposed to clamp the base, right?:face_with_raised_eyebrow::sunglasses:.

1 Like

Place the .zip file in the root of c: drive. It will probably ask you to accept permissions to put the file there. This would be something like c:\ Unzip it there. Find the cnc_ctrl_v1.ino file and double click it. Try to compile again. Your issue may be there are too many characters in the file path for it to resolve. There is a complex subdirectory structure used by the Ardunio program that could be hitting a windows limitation. I’ve seen it in the past. If you figure out what port # your Maslow is on I can give you precomplied Firmware and you can possibly skip over this problem.

Thank you

The screenshot shows that you try to upload the firmware from within the zipped file. This will not work. Try Bee’s suggestion and you should get a screen showing all the modules like this:


ok, I will try that, but 1st, when I cut the sled with relative level of success, why is this required? Is there a chance that I have already done it with the properly extracted file and that’s why things are working? What would indicate that was done vs more actions being necessary?

awesome… I’ll try this… and my port has been called com4 consistently for this what you mean?

Most likely yes, without a firmware loaded to the Mega GroundControl would not move the sled.
The firmware is updated frequently so it is good to know the upload process well. Always aim to have the latest firmware to run with the matching latest GC.


I think the firmware is loaded but the user wants to upgrade?

Thank you

1 Like

Here is a pre compiled firmware with a file to upload the file.

In fact that is all of the software in one package.

Here are instructions for - file in this download is current.

There are old versions in the Evernote information, use com4

Thank you

1 Like

Thank you so much. This should be helpful!

1 Like

FYI - You might want to join my website if you haven’t yet:

I update the files every two weeks with the latest version of the software.

The file is in the file share section of my site.

Thank you

1 Like

Thank you. I believe that sounds familiar.:sunglasses: