Maslow Home Maslow Community Garden Newsletter

Step motor spinning non-stop

Step motor will not stop turning once plugged into USB port.

Loaded Firmware 1.26 and uploaded it to my Arduino. Then the motor started spinning. Tried flipping thru settings. Tried loading a G-code to see if it would stop. Tried running calibration. Tried manual control. If you are looking at the Z-axis port, with the white side up, the problem port is the left side. When I swapped the motor connections and the problem followed the cable. Sounds like a software problem or a step I missed along the way, which I find unlikely. I planned for a week, laid it out in my floor for three days begging for the weekend and now this.

This is my first foray into CNC machines. I’m having a lot of trouble translating my engineering and hand tool wood working knowledge into the software. I know what the tool can do but the software doesn’t want to listen.

I’m also having a conniption fit with Fusion 360–I’ve been using solidworks for years, so the transition is pretty smooth, but I can’t get fusion to make a toolpath for a 2d contour…just trying to cut the initial circle for the sled. I’m down to being happy with a push button controlled straight cut.

Thanks for the help in advance!

You may want to make sure the connection to the board is solid an that no pins are bent on the connector.

Bad connections and bent pins cause runaway motors.

Where did you get the kit and which version is it?

Is it just one motor which is spinning or all of them?

Will check the connectors tomorrow. Wore out from work. Ty.

EastBay is where I got the kit from. Latest version with Z axis. Only one motor spins. But the problem will follow the connection.

There was a firmware update for eastbay that fixed the last guys similar problem… You might try searching eastbay and firmware to find who it was and how it went. That may also work for you.

They emailed me direct on top of all the help from you guys and linked the firmware direct. I’ll upload it and let you guys know how it goes.

1 Like

Good news! I used the 1.26b Firmware from eastbay and got the motors to stop spinning (!had to upload twice for anyone else having issues!). Could not apply manual control to the motors with eastbay’s groundcoutrol. Used original groundcontrol (bc I forgot about webcontrol in my sleep deprived state) to calibrate…there were complications.

THE NEXT PARAGRAPH IS ONLY A RANT, ENJOY!!
Namely I put shit together first and then something tells me to it has to be apart, I give it the middle finger and try to figure out another way. So manual it is, but my manual tape measure is in a toolbox I am currently unable to open (it’s about 30mi away buried in a storage container bc I didn’t think I was gonna be living my dream in 8 months). So, stores closed convert to metric, got it. No pencil, no pen, changed pants and left my knife in the house…I used my phone to put in the numbers and then use the damn calculator on my phone, but I hit something or didn’t do something right or saved it to a folder that doesn’t exist on this plane of existence…so I fell asleep watching old episodes of Pask Makes on Youtube, check it out.

Headed out in a bit with a notepad to get this baby going. I’ll start posting in the forums for general projects and how far I’m gonna try and push this thing.

1 Like

So after some redoing and some repositioning, I just have to go through the calibration process from start to finish and we should be rocking and rolling. thank you for all the suggestions guys.

2 Likes