Maslow Home Maslow Community Garden Newsletter

Motor just turns when pugged into USB ANYTHING

I just received the kit last week, built the frame and have been trying to get it to work for the past few days. I am trying to run it on Win 10. I have installed the Firmware & Makerverse. I had to manually correct the baud rate in Arduino. Makervers just responds now with “Unable to detect firmware version” I have already installed the latest version. I have tried various versions of the Arduino software and Makerver. I am out of ideas on things to try. So frustrated with this now.

Hello Les.

Sorry to hear that you are having difficulty. Try not to get too frustrated, it’s usualy something or somethings that have been overlooked. Lets start with who you purchased your kit from. That will help with troubleshooting your problems.

1 Like

Hi Jon,

Thanks for your help. I purchased it through EastBaySource. It came with the Arduino Mega and 3 axis controller TB6643 V1.5b. I also purchased the Arduino Due card separately but have not tried it due to the instructions indicating that additional resistors and capacitors would be required to make it work.

Thanks for your help,
Les

Ok, this helps a lot. I’m going to tag @EastBaySource so he can chime in if I am way off.

You mentioned having to change the baud rate in the Arduino IDE. Doing this and changing the communications port are normal if you haven’t configured the IDE to talk with your Arduino before. I wouldn’t worry too much about that.

To start, I want to make sure you are using the correct firmware. Since you have an EBS kit and controller shield, you need to make sure that you are using the firmware for the Arduino that is supplied by EBS Download Here

Which version of the firmware did you load?

1 Like

I downloaded both the firmware and the groundcontrol from the link. I corrected the baud rate to 38400 in the Arduino file. Then launched the new groundcontol (now in color) from the same download link. The motor is no longer spinning, groundcontol says it’s connected with no errors BUT I still can’t get the motors to respond from the calibration setting. I am now using Firmware 1.26b.

1 Like

ok, next step. Under the ACTIONS menu in Ground Control there should be an option to “test motors and encoders”. This is a simple test routine that is used to test the functionality of each motor. It will rotate each motor approximately one revolution in each direction. It will also generate an output in the message display in Ground Control. Press that and tell me what happens.

1 Like

Not to repeat anything, but if you are getting no response from the motors, please check that you have the power plugged into the Motor Shield and NOT the Arduino (should be plugged into the top plug). I have had this issue before and realized that I had it plugged into the wrong plug. The Motor Shield needs the 12V. The Arduino only needs 5V (if I am not mistaken) which it can get from the USB.

12v is plugged into the shield, 2 green lights on shield are ON, “Power” & “USB”. Groundcontrol indicates “Connected on COM5” I verified in Device Manager. Clicked on “Test Motors/Encoders” nothing happens.

So far we verified that:

  1. You are using the correct firmaware.
  2. You were able to communicate with the Arduino becasue you were able to load the firmware to the Arduino.
  3. Ground Control is recognizing the Arduino and Controller Shield (should show this in the GC messaging window).
  4. The shield’s 5v and 12v power LED’s are lit, proving that you are getting both voltages to the shield and the 12v power is connected to the shield and NOT the Arduino.
  5. You attempted a motor and encoder test but ALL THREE channels reported a failure (this should been reported in the GC messaging window).

The next step is to re-check your cable connections between the shield and the motors. Make sure they are oriented correclty and are completly seated at both ends.

2 Likes

Unplugged all 3 cables from both ends and reinserted. Changed USB cable to a known working cable. GC shows it is connected to the board. Rebooted software just to make sure. Tried running calibration software multiple times again. CG window only says “Connected on port COM5” even after trying to calibrate. All axis indicate 0mm. Also tried clicking on box arrows around home. Is there an “Enable Button” that I am missing like in Mack 4?

I would stick with just trying the “test motors and encoders” function for now. It really is a raw test and if you cant get the motors to work with it then they probably wont work with the calibration functions.

There really isnt an enable button in Ground Control like there is in Mach4.

Here is a screen cap of my window when I first start GC. You should see the “connected on port COM ##”. The next line should show which version of PCB is detected. Does yours look like this (ignore the version 1.8 number from my window for now)?

GC window

I don’t get any of that information. All I get is the first line.

So it looks like Ground Control isnt reporting that it has detected your shield. This may mean that even though you can communicate with the Arduino (like during the transfer of the firmware), GC can’t detect the shield. This explains why you cant get the motors to work. Double check the seating of the shield to the Arduino. Make sure all of the pins are alligned and going into the proper sockets.

Some more questions:

  1. When you transfered the firmware to the Arduino, what port did the Arduino IDE use to connect?
  2. Did you notice any erros during the compile and uplaod process?
1 Like

it sounds as if the fake servo mode may hve been enabled in you settings. I had
that happen to me on an upgrade one time.

Dvaid Lang

1 Like

good point, definately something to check.

Removed and reseated shield.
Firmare was uploaded using port Com5
Did not get any errors while uploading
How do I check for fake servo?

Good question, I can’t seem to find the setting in GC for some reason.

it’s buried in one of the settings menu items, I don’t remember where.

I can’t find it. I beginning to think it’s a bad servo board.

I also tried it on another new Arduino Mega board. GroundControl is now connected on COM8 but the motors still do not respond.