Maslow Home Maslow Community Garden

SVG too big to zoom out in MakerCam


#1

Hi! I couldn’t find anything that could help me with problem I have when opening SVG in MacerCam. I made a simple 3D project in FreeCad. I converted some faces to 2D drawings and export them as SVG.
Those drawings are big as near as masslow working area, and everything is in milimeters. In my case it is 1200x2400mm (near 4’x8’). When I open that SVG in MakerCam it is so big that I can’t zoom it out and it is not near the center (totaly out of focus). I have to drag the screen and look for the SVG. Somehow I mannage to find it (but I can see just a peece of it), drag it to center, and generate G-code. The size of cuts looks good when it is open in GroundControl. What could be the problem with MacerCam to show SVG so big and out of focus? I’ve try to change from inch to mm, change the resolution of px/inch, but nothing works.


#2

Hi there, sounds like some scaling issue with the export.
Why would you go from FreeCAD to SVG to Makercam to g-code, if you could do FreeCAD to g-code?


#3

At the end cuts looks ok in GroundControl so I am not sure if this is about scaling issue on export. And I am new in FreeCad, so for now I dont know how to generate g-code there :)))


#4

I did a quick test with makercam by importing a .svg from inksape, the size of a ply sheet. I can zoom out to see the full sheet. If you count the grid squares, it matches (metric) the size of a ply sheet.

If your design fits in GC fits within the the outlined (mouse-pointer) sheet calculated by the sheet dimensions in the settings and the dimensions seem ok, cut it.

For art, design objects with no demand on absolute precision and signboards, plus text, makercam can be a fast way to get cutting (if you know the bugs). Since you already model 3D in FreeCAD, the step to the ‘Path Workbench’ could be much smaller then you think. We have a few FreeCAD’ler here (including me) that will help you out.