Switching from Ground Control to Web Control Unsuccessful

I installed and run Webcontrol and it says it’s connected but won’t run motors and then the actions tab becomes ‘unclickable.’ The only thing I can find is the arduino says the mega board is on port 7 but the webcontrol states port 4 connected. I have reloaded and followed instructions but reached the point of defeat and frustration.

I get an alarm that says invalid firmware but I installed the most recent sketch and loaded on arduino.

WebControl includes the ability to flash firmware on the arduino and checks that
it’s got the expected version, so the ‘latest’ that you installed probably
doesn’t match what WebControl is looking for. Do the firmware install from

David Lang

What kit do you have and what motor shield/board version are you using? It appears you are running on windows with a COM port since a raspberry pi or linux distribution would show a tty port similar to what you see from the screen shot from my machine below.

You should have a number of controller messages once the mega turns on and starts to communicate. It is very likely that you you connected to a legit COM port, just the wrong one. If you do need to move to COM 7, it is done in the Settings->Maslow Settings and should be the first line.

Do you see the port option you need if you press the refresh button (double round arrows) and then click on the up/down arrows to fly out the dropdown box?

Did you by chance import your groundcontrol.ini file with all your groundcontrol settings into webcontrol? You might start there before you plug in the controller USB if you have not done so already.