Maslow Home Maslow Community Garden

Totally new to CNC I'm having Z axis troble


#1

I got my Maslow assembled and calibrated and was able to cut a sign I created with easel using all of the default settings except bit size. What I am really trying to cut is a Unit desk from opendesk.

I got the desk all setup in fusion360, but I set my depth to deep on my first attempt and the sled was not keeping up. I adjusted the depth to 1/16 of an inch for a 1/4 bit and resaved my file. On my second cut attempt the Z axis immediatly lowers into the surface of the plywood instead of traveling over it to the first plunge.

I tried resetting the Z to just barely touching the surface and doing a “Save and traverse height” that seemed to work but on my next cut attempt the traveled to the starting point at a good height but then rose up further and starting cutting in mid air.

Here is a screen of the setting for the first pocket I’m trying to cut, I’m using the Maslow post process:

I am a little worried I over tightened the bolt on my routers sleeve, but I thought that I would get an error similar to the sled not keeping up if it wasn’t traveling correctly.

I would appreciate any insight and please let me know if I can post any more info to help troubleshoot


#2

when you setup your cam WCS, did you select the top or the bottom of the stock? You generally always want to select the top.

here’s a couple examples from some profile cuts i’ve done:
screenshot1544060363%401X


#3

For a 2 flute 1/4 bit try tool settings (images for reference only - do not use values in images):

  • Spindle Speed: 10000 (set your router to this)
  • Cutting feedrate: 30 in/min
  • Lead In/Out: 20 in/min
  • Ramp Feedrate: 13 in/min

Cutting operations -> Passes (such as 2D Contour)

[TIP: for any text input in Fusion360 operations, make change, then right click and chose “Make default” to keep this setting for all future operations.]

  • Use Multiple Depths
  • Max Roughing Stepdown: 0.125 in (assume you are cutting 3/8 stock)
  • Use Even Stepdown: Checked

Cutting operations -> Heights:

  • Clearance height: 0.125 in from Retract height
  • Retract height: 0.125 in from Stock top

I assume you adjusted the z-axis and set zero depth.

If using the Ridgid 22002 router check that the z-axis adjustment arm has not popped out of the router body. This happened to me a number of times without any reported errors in GroundControl. This is a very weak link, and requires little force to pop out, so GroundControl will not register it as ‘end of extent’. Highly recommend doing Cheap z-axis fix if you have not already done so.

The router sleeve bolt should allow the router body to move freely in z-axis without wiggle in x/y axis. Many people find it easier to always keep the clamp open and adjust the adjusting nut.

In your screenshot you have ‘Bottom height’ set to -0.375 in from stock top. If you do not use “Multiple Depths” as mentioned above then this will be way too deep.

Questions:

  • What thickness is the wood stock you are cutting?
  • How many flutes does the bit have?
  • Can you post sample Gcode as File upload or Preformatted text?

#4

thanks for the help, the stock is 3/4 inch or 18mm. The bit I am using is the Maslow 1/4 single flute up spiral

After making the suggested changes the cut starts ok and plunges, but gets a sled not keeping up error as soon as it is supposed to move.

I did run the motor and encoder test and it looked good.

The Gcode is attached.Unit Maslow 18.nc (637.4 KB)


#5

What version of firmware are you running?

You could try increasing Settings -> Click top bar -> Advanced Settings -> Position Error Limit.
I think I raised mine to 20 or 40 when using v 1.2.4 firmware.

See bottom of https://github.com/MaslowCNC/Firmware/wiki/Keeping-Up


#6

Thanks,

I updated my firmware to 1.2.5 and was able to get the job running successfully. I am a little disappointed in the performance of the machine. This is a large cut that covers the 8x4 sheet and I think I’m going to have to break it into pieces to keep the work area in the middle of the machine.


#7

How much error are you seeing? There are errors that are much worse at the lower
corners, but it could also be that there are things you can do to your machine
to make it more accurate everywhere.

David Lang


#8

Your gcode seems to be running at 30 IPM almost all the time. Looks like I forgot to mention to use ‘Feed optimization’. Turn it on and uncheck ‘Only inner corners’. You will have to do this for each cutting operation. This will slow down movement on corners and improve accuracy. Set ‘Reduced feedrate’ to 13 IPM.

You can also turn on ‘Smoothing’ and set tolerance to ‘0.002 in’. This will reduce gcode output to only necessary movements that the Maslow can make.

Yes, had this problem too within left and right 1’ of work surface. The bottom corners can be very bad as one chain get very long, has sag, and can resonate causing wobbles. I broke down to 4 x 4’ board centered as you mention and got consistent accurate cuts.

There are a few things you can do to improve accuracy:

  • Sand bottom of sled with alt least 220grit, round over the sled edges (in and out)
  • Wax sled base
  • Balance sled vertically to make sure it does not lift from work surface when at top and bottom.