Transition to linkage kit

Ground control v1.03
Firmware updated 1/22/18

Finished installing thelinkage kit (from @pillageTHENburn) last weekend, but having an issue with calibration. Once I change my calibration selection to triangular kinematics during the step where you reattach the sled and expect the sled to be positioned to 0,0,0 my sled will zero in the X and Z axis, but goes all the way to the bottom of the spoilboard in the Y axis. Ive attempted about 6 times with same results

Thanks in advance for any advice!

1 Like

Not sure I can help. Seen this behaviour reported from previous Firmware and GroundControl versions but believe it is fixed in v1.03. Maybe it is worth a try to wipe the eeprom and rename the groundcontrol.ini in your home folder. This way you simulate a brand new user. Will search if I can find the posts.

See here: Calibration, Linkage, Alternate Sled Design
and Triangular Kinematics - Distance between sled mounting points

1 Like

If you go into the Advanced Settings what value is the rotation radius? I’ve had issues with axis movement when that value was wildly off. With that linkage set the radius should be around 270. The calibration routine will dial it in from there.


Thank you! I’ll check those settings. If all else fails, I’ll go the EEPROM / re-initialize route and update you. Thanks again


Save your current .ini file before doing anything else. It might help us in the future.


how do I get to the ‘advanced settings’? The settings tab on ground control doesn’t have a value for rotation radius. Also, I’m not finding my .ini file anywhere. . . I’m currently running off a Mac.

found the advanced settings. . . still no luck on the .ini file

the value for rotation radius was 100

The rotation radius is hidden in the advanced settings tab.

From the main window, click on settings:

Then on the top bar that says “Maslow Settings”:

A drop down menu will appear. Click on “Advanced Settings”:

You may have to scroll down the list a little to get to “Kinematics Type” and “Rotation Radius”

As far as the .ini file, I know that it is located in the default user directory in Windows. It would make sense if it was in a similar location on Mac, but I’ve never run Ground Control on anything but windows, so someone else should confirm that.

You were right, I changed it to 270 and it brought it up to within 1in of center. The default setting is 100.



That’s great news! I’ve had this problem before and it can be frustrating if you don’t know what’s going wrong. If you weren’t already planning on it, I highly recommend the auto calibration routine. Specifically step #10 of the “Calibrate Machine Dimensions” will help you dial in the rotation radius and calculate the chain sag compensation value. Both of those will increase your machine’s accuracy dramatically.

@madgrizzle: Saw your post come up as I was looking over my reply. The 100mm rotation radius is the default value. I wanted to check this myself, so I moved my groundcontrol.ini file to my backup location and when I restarted GC I got 100mm as the rotation radius.

Maybe we should add a multiple-choice question to the triangular calibration routine where the user can select their linkage system. The routine could then use the “typical” radius for that system as a starting point for the rest of the calibration. That would be 270 for the 45 degree, 136 for the top mount. Not sure what the ring system’s radius is, though.

1 Like

Sorry, I reread the first post and realized he couldn’t get to step 10. my bad

This is one of the issues with the current triangular calibration routine. We ideally want to get cuts in the corners of the work area, but this becomes a trade-off between ease of use and adaptability to various parts.

If no .ini file is present then a default rotation radius, motor Y offset, and chain sag correction value will be used. For machines with parameters substantially different than these defaults, issues could arise. It might be helpful to have either a selector for which kit is in use, or the ability to manually enter a value besides 100 before the cut is performed.


1 Like

I agree, I think we need to give people the option to input a guess. I vote that we ask for kinematics system right at the beginning of the calibration process and then ask for an estimate of either the distance between the sled attachment points or the rotation radius based on their results

1 Like

In the calibration procedure, don’t you select the kinematics type after reattaching the sled and having the sled centered? Unless I’m misreading the post (again) this suggests to me that @brewed_over changed the kinematics type in settings (didn’t change the default rotational radius) and then tried the calibration. If so, I believe the firmware was told to make moves to 0,0 using triangular kinematics while the rotational radius was 100. @bar beat me to my suggestion on moving kinematics selection to the first screen… sigh.

1 Like

@madgrizzle, don’t worry about misreading it, I’ve done that before and gone on about stuff completely irrelevant to the thread. That kinda stuff happens, I mostly just laugh at myself :wink:

That could be the case as you suggested, about changing the kinematics over in the settings first. Although he asked how to get to that settings page when I recommended changing the rotation radius. Could be he forgot how to get there, though.

@bar and @rjon17469, putting the kinematics type at the begining is a good idea. Much harder to get messed up. I agree that at the very least there should be a field to write in the rotation radius. I like the multiple choice question I mentioned earlier, but of course, I’m not a python programmer and have no idea how difficult that would be to make happen.

Side note, are there any good resources for getting me from knowing next to nothing to proficient enough to help you guys?


@madgrizzle, you are right, it does not call for kinematics until step 9, but it centers the router at step 5. turns out the kinematics selection was irrelevant to the problem (with the exception of the rotation radius default). The true problem was that I changed the sled and added the linkage, and re-ran the full calibration profile without knowing that I needed to change the rotational radius. It was further exaggerated by the fact that I went straight from a temporary sled to a full sized sled with the linkage kit.
I agree that having choices of ballpark initial settings at the beginning of the configuration would assist in this problem.
BTW, you guys have been incredible helping me troubleshoot this, hope to pass the favor on in the future.



I’m late to the party, but - Welcome to our group.

Thank you


I also struggled with the offset problem for several weeks after going from the basic sled to the round sled with the triangular linkage kit. Bar told me to go to the advanced setting under Maslow setting. After changing the default rotation radius of 100 to 260 the sled moved up to within 1.5" of the x axis. I then increased the value to 285 and the sled is very close to the center. I don’t understand the math behind the rotational radius, but it certainly has a big impact on the Y axis position. I hope there will be some changes made to the software to prevent this problem.
Thanks Bar, for your help in resolving the problem.


I have limited programming experience myself, so what has been helping me the most is actually just reviewing the code that we have in place. This was my first time using Kivy, so there was a learning curve there for me as well. I would say if you’re interested, start looking at the Python/Kivy code and how it interacts!