Maslow Home Maslow Community Garden Newsletter

Adjusting z-axis causes sled to move

Bought a maslow about 6 months ago, but for various reasons only get to play for a couple of hours per weekend so its taking me a while.
Went through the standard calibration hell (compounded by the fact I’m using a truncated workspace of 1600 x 800 so keeping chain tension is a bit of a pain), and then somehow (not entirely sure what I did differently, it just worked) all was OK. After assorted router issues, actually managed to get things cut. Hurray!
After about 3 weeks, I had a disaster mid-cut with the chain skipping off the sprocket and the router crashed to the floor.
No problems, I’ll just set it back up and re-calibrate. This was about a month ago, and its still failing.
The latest issue is that during calibration of the z-axis, hitting the lower button (and I assume the raise button but I haven’t tried) causes the sled to move!
If I ignore this and tell it I don’t have a z-axis fitted, then calibration is completed but whenever I try to move the sled down in GC it tries to move up. (Moving up moves the sled up, moving right moves right, moving left just sits there).
Tried the normal: wiping Eprom and reinstalling firmware (both 1.25 and 1.26). Similarly with GC 1.25 and 1.26.

Any ideas, or have I managed to kill it?

go through the settings again and make sure you have the top feed/bottom feed
set properly. a picture of your machine and a copy of your groundcontrol.ini
file would help us check to see if anything else is wrong.

David Lang

Hi
went back through and made sure the system was set to bottom feed - the z-axis calibration now works OK.
But movement in GC is still messed up: move left-right is OK, but moving down results in upwards movement.


groundcontrol.ini (1.5 KB)

Excellent progress :ok_hand:

I think the issue is probably related to the setting for top/bottom feed. If the machine expects one but is configured for the other you will see backwards behavior. For the way things are set up, you want “bottom feed”. The issue could also be with the left and right cables being swapped or even a combination of those two things.

OK will check top/bottom feed.
But if cables had been swapped presumably this would show up in calibration? Or is it possible to connect the left cable to the left motor in the wrong orientation?

It isn’t possible to plug the cable in backwards for an individual motor, but I do think you would be able to get through calibration with the cables swapped but I am not 100% sure…if so that’s probably an issue we should fix.

Thanks

  I'm OS for the next month, but get the feeling when I get back

the best option is just to take the system apart and start from
the beginning again.

Lee