Cannot connect to Arduino

Hi folks -
recently unpacked my M2 that had been in storage. It was working before. Now Makerverse will not connect to the Arduino at all.
Things I have checked

  • power is on, have a green light
  • replaced USB cable
  • tried every usb-c port on my MacBook
  • tried every port I can in Kerverse, which really seems to be only two - URT1 or URT2. don’t recall which it was using before
  • downloaded and attempted to install DUE firmware update, but this also fails as Arduino IDE is unable to find the device.
  • pulled the DUE off and reconnected, made sure everything was clean and plugged in.

Any ideas? Nothing seems to be able to speak to the DUE , either Makerverse or Arduino IDE. So I’m stuck.

Thanks !

sounds like you have isolated it to the due itself. there are 2 usb ports on the due. one is for program and one is for run. Depending on your case, you may not have access to both. Verify the top shield is pressed into the bottom control board completely. With some of those M2 boards, they would come apart easily because they only had a few pins holding them together. Try one USB port and then the other. and watch your /dev folder where the usb devices will show up. from a terminal you can “lsusb” command after each plug and unplug to see if you can detect it. if not, you will need to source a due board… last I looked, they were on amazon. Looks like they have gone up in price since I last bought one. I have one that I’ll never use PM me if you want to take it off my hands.

1 Like

awesome, good thoughts. i will try that. while i am at it, i didn’t think of this before but is the blue usb cable that Makermade sends something different than normal? i suppose it’s possible that the cable was damaged somehow. i could replace it with a different cable but it looks a bit different. it does not appear to be a part available on the Makermade website.
thanks !

it should be a standard micro USB cable like the android phones used to use, though now everything is USB-C. A lot of those micro cables are used for charging bike lights and stuff, so not all of them are data cables. Make sure you use one that actually has all the data wires.

Thanks! i’ll make sure it is a data cable.
as it turns out i happen two have two controller units - the first one that Makermade sent would not successfully go through a calibration process, a problem that was immediately remedied when they sent a new controller unit. i’m guessing the bum part could have been either the DUE or the shield but it seems more likely to me to be the shield ?

regardless, neither one will talk to makerverse. i can replace the DUE of course but it seems a little fishy that both of them are faulty? i never had this problem in the past.


My limited experience in working with folks who bought the M2: several had similar problems. I wonder if the Due supplier had quality control issues with the bootloader on the Due becoming corrupt or the eeprom not communicating properly to retrieve saved values. It typically manifested itself by displaying garbage characters over the serial connection at first boot and then because of that, makerverse wouldn’t detect it correctly. If you have 2, you might try taking the “bad” one and reprogramming the bootloader and then trying to reload the firmware. Nothing to lose on the bad one other than some time for tuition to learn what is going on.

Thank Orob, good advice as usual. However, I can’t connect to the older DUE either. It lights up so at least there’s that. Doesn’t matter which port or which cable, simply cannot connect to either DUE at all. Through Makerverse or through Arduino IDE. It’s acting like somehow all my USB ports died at the same time, but that can’t be the case. I suppose I can get another DUE but I have no reason to think my laptop would be able to connect to that one either. Unless , as you say, the two I have are from the same bad batch of DUEs that all go bad in time?

I would try different cables and even a different computer, maybe a old windows comp that laying around.

I had an issue with a Linux comp and the USB addresses, somehow Google machine and copying and pasting commands made it work…

Update for anyone that has this issue. After much waiting and very lackluster customer service experience with Makermade, i was able to have a zoom with one of their support guys . He couldn’t figure it out on the zoom but afterwards he sent me this link to install a driver that allowed my machine to see the Arduino :

Basically for whatever reason, the Macbook just couldn’t see it. Not sure if the issue is with the current mac OS or with the current Makerverse.

Happily i was able to connect and calibrate the machine today; now i just have to get it more precise than 4mm.

thanks for all your help!

i’ve had issues with chinese uno boards where the arduino has a knock-off ftdi chip. FTDI updated their drive to not work with these chips and it kills communication. In windows, you have to go back a few driver versions to get it to work. I’ve seen that with other boards, but not this arduino and this is the first I have heard of something that sounds similar on a mac. Interesting. Thanks for sharing your solution.

Don’t know about the Makerverse board, but those knock-off chips are usually something in the CH340 line. Those drivers are readily available and iirc come with the Arduino IDE. Of course, as with any driver, only install them from a reputable source. In another life I do a little 3018 support, the driver on this page has been proven to be reliable for both fruit and M$, but you have to decide if a moose is a reputable source.