Updated firmware with new board has problems

install my new board. Updated my firmware and ground control. ran a test.
Left motor is really jerking moving down the board on the y axis. Everything’s updated 0.81. Need some help.

I’m having problems as well with the left motor being very jerky when moving down. Right motor does not show the same symptoms. I’m at 0.81 as well.

1 Like

still no luck with ours, you?

Still jerky. I’ve done some test cuts and for the most part it’s fine but it is noticeable and seems to cause the path being cut to not be completely smooth. During calibration the left motor acts very strange and sounds completely different from the right.

sounds exactly like ours. Hopefully there is an update soon that fixes whatever is causing this…

I’m seeing this too and working on it! I too hope that there is an update soon which fixes whatever is causing this :grin:


Thanks Bar. Awesome to see that everyone’s input really makes a difference in the product, and that you guys are so dedicated to improving it.

1 Like

I think I’ve got an answer for this one. The issue was just that the PID values needed to be adjusted

The update will be part of version v0.83 next Wednesday.

If anyone is willing to test it for me (or if you just don’t want to wait a whole week), you can grab the very latest version from https://github.com/MaslowCNC/Firmware by using the green Clone or Download button in the upper right corner.

The new values I’ve chosen seem to me to be better than the old ones, but I’m still not convinced that they are perfect so the next thing on my todo list is to make these values adjustable from the Advanced Settings panel in Ground Control so we can all play with them and get the best possible performance

Let me know if anyone is still seeing the issue and I’ll keep digging!


Hey Bar,

We tested the new firmware and the cnc no longer responds at all to actions in groundcontrol. The gcode processes and according to groundcontrol, the sled should be moving, but the motors don’t move at all, and it is completely silent.

See this thread for a work-around. At least I think this is what you’re seeing :smile:

1 Like