Maslow Home Maslow Community Garden Newsletter

Help with firmware

I bought a used Maker Made and have been trying to get it set up. I am not doing the full guide because aI cannot get past the firmware possibly or I have a bad controller? Not sure but I could connect through com3 and that is about it. all tests failed and no movement at all. I have the mega 2560 I believe but it just says mega. and the due shield 1.2b I tried to update the firmware and it tells be it is wrong after trying a couple different ones. Standard 1.26 and holy. I looked at a guide on this but now it seems I am stuck at firmware because I have no connection at all. Will take all suggestions I can get. I assume I had a good firmware before but no movement and all connections seemed snug.

are you using groundcontrol or webcontrol?

been trying with web control. could always switch. I do have makerverse but I never get it to connect.

I do have a green light on the controller as well.

1 Like

Are you able to upload the firmware? I think that starting there will help us to understand if the controller is the problem or if it is something else

When use arduino ide I upload the firmware and this is where it says it is good then webcontrol tells me it is the wrong firmware. I assume I need to wipe the eprom and anything else and start from scratch but I still do not know which firmware to get.

1 Like

ahh, with webcontrol, you want to install the firmware from within webcontrol.
that makes sure that the versions match

1 Like

I will do that on my next attempt, thanks.

1 Like

Firmware installed within web control and still just gives me sled not keeping up. It acts like the software does something when I test the encoders but nothing moves and it makes no noise. If I try to test any Gcode I get the sled error. Is there a way to test my motors or control board to see if they are bad? I did buy this used.

Which board do you have? The controller will power on and communicate with the pc even if the motors are not powered. The mega can get power from the USB, but the motors run off a dedicated power source. The 12 v power supply needs to be connected to the top board or you will just get communication, but no motor movement, which sounds like what you describe. The sled not keeping up says a command was sent but the motors are not moving.

1 Like

I have Mega board and I have the 12 volt power supply for power. I have a connection and the board has a solid green light. I have tried the 12 volt power directly and to a surge protector and no difference. The motors have not moved since I put it together and I am assuming this thing wasn’t working when I bought it as I didn’t see it work before I bought it. Hopefully the pic shows up it shows the motors fail and i am connected.

image

the ‘sled not keeping up’ is unfortunantly not a useful alert at this point in
time. Since the maslow does not do any acceleration planning in the current
firmware, it expect the sled to go from stopped to full speed instantly, and the
alert is setup to fire if the sled is more than 2mm from where it would be if it
did move at full speed.

The PID tuning isn’t that aggressive (and shouldn’t be).

In your settings, there is a setting for this alert, change it from 2 to 20.

now, this doesn’t solve the problem of your motors not turning, but the sled
keeping up alert has not turned out to be useful like I thought it would when I
proposed it.

David Lang

It does look connected and the motors are failing. That’s usually caused by an issue with the power supply. Is there a light on the power supply?

Where is the power supply plugged in? Does the green light go on and off when you plug in and unplug the power supply?

I need to double check the power supply. I don’t recall seeing any lights. Not home so I will check tonight.

1 Like

Power supply has light on so I assume it working. Do I know if it is enough power? Not at all.

When you plug it into the Maslow board to you see a light come on the Maslow board? Does that light turn off when you unplug it?

Green Light comes on when plugged in and goes off when unplugged. It’s a mega controller. What if I had wires in the wrong location?

That would cause the symptoms we were seeing. I’d give it a go again.

Thanks for this information. I also have the same situation.

1 Like