Maslow Home Maslow Community Garden Newsletter

WebControl:51.27, Controller:51.28


My computer/arduino is a little bit confused… when i open the Web control it said:
Warning, you are running a Holey Calibration firmware that is newer than what is included in WebControl. This version may not work correctly with this version of WebControl.
WebControl:51.27, Controller:51.28

I think this is because I was playing with Markerverse … where i have some troubles when I try to work with a gcode file… but this is other problem.

How do I put the controller version in 51.27?.. I try in ACTIONS->Upgrade Holy Firmware to 51.27… but dont work… how do i solve this issue?..

thank you

It is a warning only and should still function.

somthing is wrong, i delete all and reinstall webcontrol, now if i try to draw a simple circle, it said

Alarm: Connection Failed or Invalid Firmware

whe webcontrol start it said… and the versions dont match, is this the problem?

Connected on port /dev/ttyACM0

Sending: B05
WebControl 1.27
Firmware Version 1.26

Sending: G21
Sending: $$
firmwareKeyString Exception: value = 2440
firmwareKeyString Exception: value = 1220
firmwareKeyString Exception: value = 470
firmwareKeyString Exception: value = 260
firmwareKeyString Exception: value = 54
firmwareKeyString Exception: value = 180.5
firmwareKeyString Exception: value = 1766
firmwareKeyString Exception: value = 69.85
Exception in thread Thread-2:
Traceback (most recent call last):
File “”, line 914, in _bootstrap_inner
File “site-packages/gevent/”, line 177, in run
File “”, line 862, in run
File “Background/”, line 32, in start
File “config/”, line 604, in receivedSetting
File “config/”, line 475, in syncFirmwareKey
File “Actions/”, line 557, in updateSetting
TypeError: unsupported operand type(s) for /: ‘str’ and ‘float’

Sending: $0=2440
Sending: $1=1220
Sending: $3=470
Sending: $4=260
Sending: $6=54
Sending: $8=180.5
Sending: $11=1766
Sending: $13=69.85
{“hostAddress”: “”}
starting UI
I’m connected!

My guess is that you need firmware version 51.26 or greater to use holey calibration and if that is what webcontrol is expecting based on your webcontrol.json config file, it will not work unless you either actions->upgrade to holey firmware or delete your config file and start totally fresh.

Thank you for the fast answer, tomorrow i will folow what you said


ok, now I have:
Connected on port /dev/ttyACM0

I’m connected!
Sending Board Data
Sent Board Data
Sending Board Cut Data compressed
Sent Board Cut Data compressed

Sending: B05
WebControl 1.27
Firmware Version 51.27

Sending: G21
Sending: $$
firmwareKeyString Exception: value = 800
firmwareKeyString Exception: value = 17.018943
firmwareKeyString Exception: value = 20
Sending: $15=800
Sending: $16=0.000000
Sending: $29=1300.00
Sending: $37=17.018943
Sending: $42=20
Sending: $45=0.00000516850
Sending: $46=40.0000
{“hostAddress”: “”}
I’m connected!

When I run he triangular calibration it said:

Sending: M3
Sending: G0 X-966.0 Y+368.7
Sending: G1 Z-7 F500
found adjust Z-Axis in message
at resume run with manualzaxisadjust = True
‘Data’ object has no attribute ‘pausedUnits’
at resume run with manualzaxisadjust = True
‘Data’ object has no attribute ‘pausedUnits’

Paused units… what does it mean?

are you using a motorized z axis? if so, please set the z axis installed setting to TRUE in settings menu -> maslow settings:

no, i dont have z axis and this value is in OFF…

It means there is an error in webcontrol with the manual z axis.

taking the adventage that you are here…
I am calibrating in ground control now… and i have this error… what is happening?

I am begin to feel very very frustrated,

Ground control does not work with holey firmware, so you need to use webcontrol and flash bach your controller to version 1.26 or 1.27

Ready, with ground control the things are running “quasi” smooth. I draw a pettern in the middle, middle top, middle bottom, left uo, mid, bottom… and is practicaly the same, very very little differences… so I can said Ground Control is ready. Y make a backup of the groundcontrol.ini file shutdown everything and here I am.

Now I want to run Webcontrol… if I understand what I read, I have to do the folowing:

  • If I dont want to recalibrate anything, the only thing I have to do is IMPORT graoundcontrol.ini and thats all, it wil run like Groundcontrol
  • if I want to refine the calibration, I just have to upgrade the Holyfirmware to the Arduino, and then run the holy calibration. question, which is the configuration file for webcontrol? defaultwebcontrol.json? can I backp it and restor it at any time? or I have to recalibrate with the restore?
    When I do a calibration process… the results of this calibration where are stored?

If something dont go good and I want to go back to groudcontrol, the process is:
restore de groundcontrol.ini
upgrade de stock firmware
run de calibration process?.. it’s necesary?

thats all, just traying to understand where the things go, modify, restore, run, etc…

Best regards.

Yes that sounds correct. If you decide to go back to groundcontrol after webcontrol, the .in file from the original calibration will work still, but there is no way to move calibration information from webcontrol to groundcontrol. The webcontrol config file is webcontrol.json and is in the username/.webcontrol folder.