Maslow Home Maslow Community Garden Newsletter

I redid my system

Okay so I tightened all the loose screws, added locktite. Checked frame for level. Downloaded webcontrol (linux single file)- I have some problems getting it to launch a second time. I have to click the program- check task manager or terminal to see if running. Then call up webcontrol on firefox via history or book mark. Terminal gives error bad symbol- get-date. But if I call it manually as described above I can run it.

It controls the router much more smoothly than groundcontrol. Ran calibration entered those numbers and I am getting pretty straight lines. But running triangular calibration does not work on webcontrol. Says this feature is not available and crashes. So I ran the file on groundcontrol and entered those numbers back into webcontrol. They seemed to work.

But I am having problems creating a square box via easel. It always comes out longer than wide. But if I enter dimensions and manualy cut with webcontrol the box is square.

So I think the problem I am having now is mastering gcode- or at least going from a cad / cam to gcode.

I did not mess with firmware though webcontrol gives error saying my firmware is newer than the recommended firmware. Should I change it?

There should be an option in webcontrol to use either triangular calibration or
holey calibration (6 holes, 12 measurements). you have to flash the firmware
when changing between them (save a copy of your config, it’s now an option from
one of the menus, before you switch)

please post the g-code that you say isn’t comeing out square.

David Lang

Heres the gcode. Ill look into flashing the firmware

Untitled (1).nc (765 Bytes)

so looking at this, you are doing some small moves in the corners, did you tell your system to round over the corners? (the movements are only ~5/100 of an inch, so you probably won’t see the effect)

how far off from square are you measuring the result

G20
G90
G1 Z0.15000 F9.0
G0 X6.84244 Y0.99884
G1 Z-0.06389 F9.0
G1 X6.88553 Y1.00754 F30.0
G1 X6.90524 Y1.01740 F30.0
G1 X6.93805 Y1.04669 F30.0
G1 X6.95007 Y1.06519 F30.0
G1 X6.96353 Y1.10706 F30.0
G1 X6.96463 Y6.88385 F30.0
G1 X6.95593 Y6.92694 F30.0
G1 X6.94608 Y6.94666 F30.0
G1 X6.91678 Y6.97946 F30.0
G1 X6.89828 Y6.99149 F30.0
G1 X6.85641 Y7.00494 F30.0
G1 X1.08649 Y7.00604 F30.0
G1 X1.04340 Y6.99734 F30.0
G1 X1.02368 Y6.98749 F30.0
G1 X0.99088 Y6.95819 F30.0
G1 X0.97885 Y6.93970 F30.0
G1 X0.96539 Y6.89783 F30.0
G1 X0.96429 Y1.12103 F30.0
G1 X0.97299 Y1.07794 F30.0
G1 X0.98285 Y1.05823 F30.0
G1 X1.01215 Y1.02542 F30.0
G1 X1.03064 Y1.01340 F30.0
G1 X1.07251 Y0.99994 F30.0
G1 X6.84244 Y0.99884 F30.0
G20
G90
G1 Z0.15000 F9.0
G0 X0.00000 Y0.00000
G4 P0.1

try this instead
G20
G90
G1 Z0.15000 F9.0
G0 X7 Y1
G1 Z-0.06389 F9.0
G1 X7 Y7 F30.0
G1 X1 Y7 F30.0
G1 X1 Y1 F30.0
G1 X7 Y1 F30.0
G20
G90
G1 Z0.15000 F9.0
G0 X0 Y0

Where did this specifically occur? Did this occur when you pressed the ‘Triangular Calibration’ button on the Actions page? or when you tried to do something on the Triangular Calibration page?

If you run webcontrol and want to use holey calibration, you should use the firmware that is included with webcontrol. The stock firmwares are the same, but the holey calibration firmware is modified slightly to work better with webcontrol. You should only need to go to “Actions->Upgrade Holey Firmware:51.27”

1 Like

When I click the button on actions page. It opens the calibrate page then it gives error. It does start the cuts though. But if you click stop button it gives same error.

I am going to try and change firmware today and see what happens.

Thanks I will try this now.

Well I clicked upgrade to holey firmware.

it said upgrade successful.

It overwrote all my ini files. I should have thought to make another copy of them first. It erased all my chain lengths.

So Ifigured I would have to start over again And now I cannot communicate with my arduino board at all.

testing motors / encoders provides fails.

Neither ground control nor web control can communicate.

So couple of questions:

  1. All my laptops are linux. Does windows run these better? Are some of my problems linux based? I know my old laptop outside maybe some of the issue, and I have a much newer laptop I can use but it also linux.

  2. What are the steps to start over from scratch? I seriously hate doing that chain measurement thing all over again but it seems I lost whatever data I had on the board when I updated. My numbers are still in my settings- but it cannot recognize chain length or sled position and cannot communicate with motors.

seems lots to unpack here…

Webcontrol doesn’t use .ini files. The config is stored in webcontrol.json so if the .ini file got overwritten, I think it must have been done by ground control somehow. However, chain lengths aren’t stored in an .ini file. Did you get a message about invalid chain lengths right after performing the update? If so, that’s an issue inside the controller (no .ini files involved with that). Upgrading firmware doesn’t normally cause you to lose chain lengths though, so that’s odd.

Does webcontrol report being connected to the controller (the very top right ‘alert’ will be green with the port name… /dev/ttyACM0 in my case)

image

I don’t have a controller connected to a linux box so I can’t say. I build the linux file using ubuntu 16.04 virtual machine. I don’t know if it matters that I use ubuntu or not (for compatibility with other distros).

So you got a message about invalid chain lengths after doing the firmware update? You can reset the chain lengths by using the Actions->Set Sprockets Vertical page. Did you mark the chain link that was on the top tooth after doing your first chain extends?

Attached is errors being thrown in terminal. 1st is screenshot,png of boot up of webcontrol. 2nd is screenshot1.png of moving sled.

I did manage to get it talking to the board- but now everything runs backwards. Zaxis now moves entire sled. Y up moves y down and slightly to left. Ydown moves sled up and to the right. X right goes left and slightly down. x left goes right and slightly up.

No I did not mark the vert sprocket. But I will when we get this going again.

Second problem is that webcontrol is losing serial connection over and over. I am concerned the board maybe going bad. I did unplug and replug usb and power cord and allow to it restart. That seemed to stop the connectivity problems for the time being. But with it running backwards now I dont know what direction to go.

I am going to check to see if my chain off bottom setting got messed up.

Which release of webcontrol are you using? 0.907?

yes. Ver 0.907

I fixed the reverse issue. It should have been chain off bottom.

Fixed the chain length error.

Now we are back to the original problem:

cutting a square square:

I used D Lang’s Gcode he posted above to cut a 6" square:

I ended up with a 6" y axis and 5 5/8" x axis

So now to figure out the calibration issue that I was working on originally.

BTW after I upgrade to holey my screen still has the holey calibration option grayed out.

So some progress at least, to where we were. Now to figure out how to get the holey calibration to work.

I don’t think you are running the correct firmware (that error message in image 1). You are running singlefile version, correct?

Yes I am running single file.

I see the avrdude.conf file is missing from my linux VM. I’m creating a new releases (v0.908) with it included. I’ll post when its up and you should be able to update via Actions.

1 Like

Release released.

Okay I will try it

As for the second screenshot error. I haven’t seen that error and wonder if it’s a webcontrol issue or an issue with your linux setup. What linux distro are you using?