Maslow Home Maslow Community Garden Newsletter

WebControl and Z-axis

I use WebControl on a RasPi. When the Z-axis is controlled by gcode, then it moves correctly. But when I manually move it, I have to push the “wrong” arrows: If want to plunge in, I have to press the “arrow down”. Besides that all the other arrow buttons behave like they should.
Any ideas, what is wrong?

perhaps in your gcode, you have negative set as moving up. Check your gcode generating software and see if it is moving negative to cut deeper or positive.

1 Like

I had a similar issue using webcontrol. I found out that if you put a - (neg) sign in front of your Z-Axis calibration setting, you could reverse the direction but that just added more complications when calibrating it. What I finally had to do was reprint a new servo mount for the router. My servo comes out 90 deg /perpendicular to the router shaft and by moving the servo to the other side of the router (flipping it 180deg), I was able to go back to positive numbers. It took me about 6 frustrating weeks to get my Maslow to work properly.

That’s exactly what I did: I added a negative value to change the direction.

@Orob Can I also change the direction by flipping some wires at the Z-axis motor?

I wouldn’t go changing wires if a negative will do it in code. Here’s the thing:

if your up/down buttons work correctly, then your system z pitch value in the settings is set correctly and your gcode you are feeding it is backwards… it is trying to cut up rather than down. If it does this in the calibration step, then that is a problem, but if it does it with gcode, fix the gcode generator. Reversing the wires will not fix the issue if the gcode is opposite the system regardless of how you do it.

1 Like