Maslow Home Maslow Community Garden Newsletter

WebControl losing connection

I can get the webcontrol to connect to the com and everything but after a few seconds it throws an alarm saying Connection failed or Invalid firmware
Then reconnects and throws the same error

I searched the forum tried all the suggestions but still can get it to go away

I can connect and do everything in makerverse with no issues

Thanks

I’m connected!
Sending Board Data
Sent Board Data
Sending Board Cut Data compressed
Sent Board Cut Data compressed
Error checking pyrelease: could not convert string to float: ‘2020-05-26-2021’
None
Connection Timed Out
Trying to connect to controller on COM3

Connected on port COM3

Connection Timed Out
Trying to connect to controller on COM3

Connected on port COM3

is makerverse running in the background when you are trying to run webcontrol?

That looks like string text '2020-05-26-2021’ is incorrectly being converted to a floating point number which should not happen and is probably a problem in communication between Malsow firmware to Web Control UI. Date/Time numbers should never be converted to a floating point numbers and should probably be converted to Integer Unix Time Stamp instead. This probably crashes the whole Web Control UI: leading to the COM port failures.

Please provide info on:

  • Maslow firmware version you are using (should be v1.26 minimum). If not then flash firmware to newer version.
  • Web Control Host OS and Version (Raspberry Pi v3-4, Windows 7-10, Mac OSX (Mountain Goat or whatever makes people spend more money)
  • Web Control version.
  • Web browser (FireFox, Chrome, Safari) and Version you are using.

All points are important, to debug the problem, so don’t omit any. If you need help identifying info please let me know.

Orob I didn’t have makerverse running in the bg first time I tried it didnt work so I tried it with makerverse running.

Tinker
I’m running the latest version of maslow
Host computer is on windows 10
webcontrol v.94
browser is chrome Version 90.0.4430.212

thanks for the help guys

Just looking for an easy fix. Which controller and shield version do you have?