Maslow Home Maslow Community Garden Newsletter

Webcontrol Need to Refresh Page Often

New to Maslow/Webcontrol. Did not find this problem in a forum search.

Just built a Maslow, overall its working well, but have a constant problem w WebControl. Seems to be sync issue between browser and WebControl server. After every command or two I have to refresh the page in order for WebControl to work again. Exmaple;

Upload gcode file successfully
(WebControl non-responsive)
Refresh page (using refresh button on browser)
Open gode file successfully
(WebControl non-responsive)
Refresh page
Press play to start cut…

Note that each refresh/reload typically takes at least 30 seconds.

This is what I now have to do every time I use WebControl.

The cut itself runs fine, only have this problem when issuing commands via WebControl.

I have tested this on both Windows 10 and Android using Chrome on both. Same behavior.

I normally connect to WebControl via a router, but have also tested this by connecting directly to the WebControl AP. Same result.

Troubleshooting suggestions appreciated.

What platform is webcontrol server running on? Can you see any of the log messages? Those may help point to a cause. I’ve had webcontrol run on Linux, raspberry pi, and windows all without issue.

Raspberry Pi.

I have the Rpi mounted next to the Maslow Arduino connected by USB.

I’m fine with logging onto the Rpi and looking at webcontrol log files. Where might I find them?

On a rpi, if you stop the service and the manually start webcontrol from a terminal window then you can see its output in real time. Perhaps that would tell you more than digging through a long log file. Is it on a 3b or newer? Are you running the full desktop or headless server?

3B, headless.

Can you point me to command line syntax for webcontrol?

Is it just a normal service that can be controlled using systemctl?

that is what I’m running. From ssh:

>sudo systemctl stop webcontrol

>./webcontrol

in the webcontrol folder

Thanks. Will take a look.

I should clarify, webcontrol is working. I can control the Maslow and am successfully cutting. I just often have to reload the page between commands.

that should not happen. what browser are you using on what platform? I use webcontrol on my phone and on my laptop with chrome and I never reload it. I tried it in Brave and it didn’t do very well. not sure why.

Normally Chrome on Android, but have had same issue with Chrome on Windows 10. Same issue going thru router or direct to Webcontrol AP.

Just logged onto Rpi via SSH and even a simple terminal session is hanging periodically…so something odd going on systemically. Likely a network config issue.

I used the packaged WebControl system image and Ive not tweaked anything. Hmmm…

Is your pi overclocked and overheating? You might be starving it for power perhaps.

Checked clock and temp. Not overclocked, temp 44C.

Also thought it could be a software version/dependency issue so I ran a full apt update/upgrade…still same problem.

Was just thinking of power/electrical noise. Will check power next.

If you plug it into a tv or pc monitor, you can watch for the lightening bolt in the upper right when it gets low on power.

Yes, I’ve seen that on Rpi’s before. Will double check capacity of power supply tomorrow…and I have an old monitor I can plug in to watch for low power.

As I recall it shows up when running VNC too so may try that as well.

So far I have:

  • confirmed CPU is not over clocked or over temp
  • confirmed good power supply (checked voltage, swapped with know good, checked voltage again, all good)
  • confirmed not a hardware problem by swapping SD card into a known good Rpi and firing it up as webcontrol.

Had same hanging issue in all cases.

My original install was from the pre-built webcontrol image, so I am now building another image manually to see what problems crop up. I’ve muddled my way thru getting Docker installed (a problem area on Buster). Docker has now successfully run its “Hello World” test app.

My config is an Rpi 3B, running Buster.

I could use a bit more detail on the final lines of the webcontrol install.

"

  • Mount a data/config volume at /root/.WebControl
  • Expose port 5000
  • Run with privileged: true security context for USB access.

    "

For example, run what with ‘privileged: true’?

Open to any other troubleshooting suggestions too.

You don’t need it to run as root

I took a break from fiddling with building a manual image and gave the pre-packaged image another shot. I built it to a 16GB Class 10 SD card. It seems to have resolved the issue.

The original image, from the pre-packaged image, was built to an 8GB Class 4 SD Card. Per respberrypi.org an 8GB card should be adequate for Buster Lite and they are ambivalent about the card class. I assumed that WebControl was not IO intensive so card class should not matter…correct?

I’m not certain this is what caused/solved the problem, but at least it’s working now!

2 Likes

yeahhh…