Maslow Home Maslow Community Garden Newsletter

Webcontrol stopping unexpectedly

Hi all. My Maslow has been sitting idle for quite some time, but I am finally back using it again. Successfully made a cut yesterday, using Webcontrol for the first time. Imported the groundcontrol.ini and everything worked perfectly.

Today…not so much. Webcontrol keeps stopping around line 50 in the gcode, unexpectedly and gives no errors. Any ideas what might be causing it? It is a relatively simple cut. Diagnostics report and gcode are attached.activity board.nc (21.0 KB) wc_diagnostics_20201128-115918.zip (201.0 KB)

I am running Webcontrol on a Windows 10 PC. I even reinstalled on a new PC since I suspected the first PC could have been the issue (CPU always 95-100%), but the new PC had the same issue as well.

Thanks for any help.

Is buffering turned on? If so, try turning it off and see if it performs differently.

Also, you can put the controller in fake servo mode and run the code in a simulation. It would be good to know if it always fails at the exact same line.

Thanks for the quick reply. Buffering was on. I will try turning it off.

It mostly fails at line 54, though sometimes earlier.

Actually, turn on “truncate digits” option. It’s definitely a buffer overflow and part of problem is the number of digits being sent.

In general, I recommend against buffering gcode… it was too problematic to deal with and there’s still likely some issues using it. I don’t think it makes a huge difference in speed to buffer or not.

Thanks, I will try both. Now that I think about it, I had a problem with buffering when using ground control back in the day.

did your code have an R (radius) command in it? That has only recently been added and before, it would just stop.

Changing those two settings fixed it. Back in action!

Thanks for all the help!!

1 Like