Maslow Home Maslow Community Garden Newsletter

Webcontrol keeps going to idle, ground control works fine

hello all,

The issue I am having is that when I use webcontrol that I installed on a raspberry pi 3b+ after I start the cut it gets to around 1% and then just sits there on idle. If I run the same gcode file through ground control from my laptop it runs as it should. Just looking for what to do next, thanks for any help!

RJ

is the gcode buffer option on or off? (maslow or advanced settings - I’d have to look at it again later to be sure).

I had to turn it off for webcontrol and I never got back to investigate why. Try that.

also can you see any messages from webcontrol in the log file as to why it stopped?

is the Z axis working? what should be happening at that point?

David Lang

I will check the gcode buffer setting and the logs.

Yes the z axis is working up until the point that it stops, its not always at the same spot but its normally when raising back up after a pass.

Post the gcode, webcontrol might be paused. WebControl and GroundControl process gcode differently.