Maslow Home Maslow Community Garden Newsletter

WebControl won't load

I have had my maslow working for about a month and cut out a few things, but not without chasing issues all the time. Lost connection, recalibrating repeatedly, Makerverse vs. Webcontrol, No picture on WebControl, and the list continues… but I am enjoying the process and learning how it all works, but I have hit a snag. Webcontrol will not start. When I run it in the terminal to start it, it runs about 10 lines of script and closes the terminal on its own. After a few tries and some quick print screen fingers I “caught” the script and have attached the photo. Can anyone help me with what is going on here?

Nicely done!

I’m not a webcontrol expert, but it seems to me like the settings file might be corrupted and when the program is trying to load the settings it’s failing and crashing. Can anyone else provide any more info on what we’re seeing?

Is your webcontrol.json file corrupt? If you move it the system will create a new one. If it loads, then you are good. But you will need to check all your settings. If not…?

1 Like

This worked just fine, almost feel bad wasting your time…should have thought of this, thank you for the reply.
On another note, is it typical for webControl to not display the project it is cutting? I can cut a project, and watch the “bullseye” move around the layout but I can’t see an image of what I m cutting. Perhaps I’m missing a setting?

I have seen it once on my system and I don’t recall what fixed it. Would you mind sending the gcode so I can see if I can view it on my machine? I wonder if it is a gcode issue. You can send in a direct message to me if you prefer.

1 Like

sadly Im not exactly sure how to send you the gcode in its entirety, unless its just the file I load into webcontrol. but I did get a screenshot of the opening script for webcontrol and the first several lines of my gcode for the project. I have cut 4 different things and I have never had an image of any of the projects on Webcontrol

it is just the file you loaded on your system. Looks like you are running webcontrol on windows. have you clicked on the 3D or the ortho or the reset buttons in the upper left of the window below where it says Webcontrol?
image

Pocket name.nc (344.5 KB) Here is one of the files I used. I have tried all the buttons and I have looked through all the setting menus and nothing seems to be obvious there

if it makes you feel better, it doesn’t show up on my webcontrol either. I try to limit the decimal places to 4 and use the grbl output postprocessor… after looking at your file in the estlcam viewer:

I wonder if there are just too many lines too close together so the display doesn’t draw them. I only know that webcontrol uses opencv to do the graphics so maybe someone else and comment on why this may not show in webcontrol.

But on a whim, I noticed that your gcode output is in all lower case. all the g, z, x, y, i, j, m commands are all lower case… does it matter: not for cutting, but apparently it does for the display because with a little CTRL H action in notepad, I changed each to caps and this is what you see now:

here’s the file. make sure you use the GRBL postprocessor for your gcode. if you can, specify capital letters.
Pocket name2.nc (344.5 KB)

Wonderful!! this worked perfectly. I use KrabzCam to generate my toolpath and Gcode, and there is a check box for Uppercase gcode… simple fix, just didn’t know it had to be uppercase. Thanks for all your help.

1 Like