Maslow Home Maslow Community Garden Newsletter

WebControl Buttons Stopped Working

Hello! I’ve been working on calibrating my Maslow setup and I’ve run into an issue with WebControl. I had it working great last week; calibration went well and I was cutting some test items. I had ordered the ring setup and z-axis motor (I have the original Maslow with the angle brackets) and got them installed and started the calibration over…but now the software just doesn’t want to work. I’m telling you, I had NO issues with it before but now, the buttons won’t “press” when they’re touched (unless you maniacally reboot the software and unplug/replug the USB cable).

Something interesting though, the X,Y position readout (next to the Board toggle) still changes when I press in the button’s area… but it’s like the software just doesn’t register the push. The dropdowns will open, but the option you click won’t open.

Has anyone else experienced this? I’ve tried using the MakerVerse software, but run into some calibration issues and I think I like WebControl better so I’d prefer to get it up any running!

it sounds like webcontrol crashed. What system runs webcontrol? It sounds like your webcontrol.json file is corrupt.

What’s weird is that it crashes off and on. Sometimes, it will work for 5-10 minutes and let me control motors as I calibrate and then it just won’t let me do anything, though it’s still processing input. I tried pulling the .json file out of the file tree to see if it would build its own on start up, but it won’t make it past the initialize process in the terminal window.

I’m running it on a Surface Go with Windows 10. How can I get a working .json file? And, what could have caused it to crash from one minute to the next? All I did differently was install a new sled and turn the Z-axis status to “on”.

This sounds like your webcontrol.json file is corrupted. I was having a lot of problems with this a few months ago. The only easy fix is to replace it with a backup file that you hopefully made after calibrating your machine. If not then you may have to go through the setup process again.

1 Like