Maslow Home Maslow Community Garden Newsletter

X and Y are backwards

My M2 is working now but both X and Y move the opposite direction. I tried swapping the left and right motor wires (even though they were correct) and the Y axis got fixed, but the X was still wrong. So I put the wires back to the way they were.

My setup is with chain over the gears (with water bottle weights) and I’ve tried the over/under setting both ways but the X/Y are both still backwards.

It seems to me that the chain over/under setting is not working as it’s supposed to. Anyone have any ideas what to do?

It sounds like you did the right thing. I would expect the over/under setting being wrong to cause exactly the behavior you are seeing. I’m very surprised that changing it didn’t fix the issue.

Maybe try changing that setting and messing with things like changing it an then reconnecting?

Parameter $80 should =1 correct? I’ve tried =1 and =2 and both X and Y are still backwards. I also tried a full power cycle of both the RasPi and Arduino between changes.

It seems to me that the $80 parameter is not working in the newest firmware. Could someone with the newest firmware swap to the other state for $80 and verify that the directions change for them?

Sanity check: When the Y value increases, the router should move UP correct? (This is not an entirely stupid question if you think of the material moving under the cutter instead of the cutter moving over the material.)

Yup, that is what the expected behavior is. Good question though, that would be a neat solution.

I haven’t messed with the latest firmware, but maybe it should be = 0 ?

I tried =0 also; no change. It really seems like the firmware is not using $80 correctly. I think I’ll try to find an older version of the firmware and test that.

$3=4?

I think that’s (only) for Z axis - but I will try it. Thanks for the suggestion.

I tried changing $3=0 and as I expected, it only changed the Z axis, X and Y were still reversed. I am using the firmware from here: GitHub - makermadecnc/MaslowDue: Maslow CNC, second generation based on GRBL and Arduino Due

I note this paragraph: “Please note that the chain configuration of this supplied software is for an ‘under-sprocket’ chain to a sled-ring system. The sled-ring keeps the math to a simple triangular system and that makes it easier to compensate out any errors over the working area.”

Is that still accurate? It does not support $80 for chain ‘over-sprocket’? If so, this is a major disappointment as my frame is really set up for chain over sprocket with weights.

Hmmm… Looking at the source code, in system.cpp it appears that it does make use of settings.chainOverSprocket but I have not yet tracked down if $80 is directly tied to this as is implied. I’m still digging…

1 Like

Anyone using the newest firmware for M2 Due? If yes, please change the $80 parameter and see if your X and Y axis go in the wrong direction.
If it is currently =2, change to =1.
If it is currently =1, change to =2.

(I’m also posting this to Facebook group for more visibility.)

1 Like

Thanks to some help on Facebook, I found the answer. This link:
https://www.diymachining.com/downloads/GRBL_Settings_Pocket_Guide_Rev_B.pdf
contained the magic information. Orob was almost correct, changing $3=7 was the magic I needed. I’m finally up and running after a week stuck with reversed X and Y.

1 Like

Just worked for mine as well! Thank you very much. Build to follow!!

1 Like

Thanks for helping solve this task.

1 Like