Maslow Home Maslow Community Garden Newsletter

X origin changed after program pause?

After pausing midway through a horizontal cut, I got an ‘sled not keeping up’ error. Following past posts, I tried to use the ‘go to’ g code line function, backing up a few lines to a line with appropriate feedrate and z instructions. However, it seems like the x component of the origin shifted several inches. The router plunged into the slot from the previous cut, perfect in the y direction, but about 3 inches to the left of where I expected, and continued ploughing through the cut about 3 inches further than expected before I stopped the cut. What happened?

after you have an error like this, the machine has lost it’s position, you need
to reset the chains (set the sprockets to 12 o’clock and hang the marked links
on them, or go through calibration and feeding out the chains if you didn’t mark
the links at the end of calibration)

David Lang

Ah, I didn’t realize that. Is it best practice redo the whole calibration cut sequence as well?

best practice is to mark your links so you don’t have to :slight_smile:

but if you loose calibration and don’t have the links marked (and don’t want to
try and figure out what link to mark after the fact), you need to go through all
the steps that feed out chain, you can leave all values the same.

I marked my chains the first time I ran into this problem, so I don’t remember
the details

David Lang

Well lesson learned. I definitely marked the links this time!

I’m sorry this happened; it shouldn’t have. I wish we could figure out why this happened and fix the root cause, which sounds like a software issue.

What firmware and ground control versions are you using?

No worries; the process of getting to know this machine is so fun. I believe i’m using firmware v1.26 and groundcontrol v1.26.

1 Like