Y axis cuts are wrong -- tried re-calibrating over and over

I have a less than year old M2 kit that I installed on a rolling frame. I am using the metal unistrut top frame where the motors are mounted and running chain over sprocket in the settings (although I had to enter $3=7 to get the XYZ axis’ to go the proper directions). I calibrate everything, makerverse verifies I am within 1mm of tolerance/accuracy. When I cut some test squares, let’s say 20"x20", it’s accurate along the X axis and is exactly 20", but not accurate along the Y axis. It’s off by exactly 1/8".

I double/triple/quadruple checked the chains and the sprockets are at 12 o’clock when I bring the chains taught and center them up.

Also, I took the frame apart yesterday and verified that everything is squared up and so on.

When I run the edge precision, it tries to change my motor distance to less than it actually is. I’ve measured it over and over to make sure it’s dead on to the center of the sprocket.

X and Y compensation values, after calibration, were X=1.004% and Y=1.003%. I tried to modify the X and Y axis compensation by telling it that it’s off by .625% (which is 1/8" of 160 eighths or ~20 inch). When changing to 1.629(calibration of 1.004 + math above at .625) … same issue. When changing to simply .625…worse.

I’m using fusion 360 to generate simple code via post process. I’m telling it to cut outside of the line to ensure it keep the whole 20"

I’m close to taking it off of this frame and migrating it to the standard wall mount to see what happens. The idea of that burns me out a little bit.

Anyways, anyone know how to fix either X or Y axis being off like this? (it’s never been right…ever :frowning: )