Maslow Home Maslow Community Garden Newsletter

Personal calibration issues

hoping someone can help set me (my machine) straight.
I’ve been through a bunch of topics, videos, and a couple of versions of software…
at this point it’s all too jumbled for me to make any more sense of it.

issue: moving in Y axis… sled movement is straight up and down, and accurate(ish).
moving in X axis… over the course of 200mm, sled will creep up in the Y axis a bit.
it returns to proper Y height when moved back to the center of the work area.
seems there is something wrong with my measurements, but unsure which fields to edit directly.
I’m used to 3d printers and when something is off in x or y or z, I can tweak a specific setting.
here, there are calculations that are based on indirect factors, so I’m not sure what to tweak.

I’m on the M2.
unsure which calibration steps to follow, but I’ve found and tried at least 3 different sets of instructions.
some made more sense than others.
currently on: Makerverse v1.1.2 #257
with the firmware upgrade that went with it on the controller.

I’ve assembled and run 3d printers and lasers for the past few years and this here has me stumped.
I’m sure it’s something simple, just… my brain isn’t finding where the settings for this issue are.

open to any advice.
thanks in advance.

                                     |mm   |inches|

|machine width |2438.4|96.0|
|machine height |1219.2|48.0|
|motor distance |2471.4|97.3|
|motor height |977.9 |38.5|
|full length of chain |3360 |132.3|
|calibration chain length|1660 |65.4|

hopefully the relevant info is here and there is an obvious flaw. :slight_smile:

the issue is most likely the accuracy of the distance between the left motor sprocket at 8:00 position to the right sprocket at 4:00 position in mm reported in $83=(some number you measured in mm usually 3000 ish).

the other possible cause could be the beam height:


you need to measure from the top of your work piece to the middle of your motor shaft. It is an inch from the middle of the motor shaft to the top of the beam it sits on and then I usually measure from the back side of the beam (top left side of red in pic) to the top of the work piece in mm and put that in as $84 or in the calibration, put that in the page in the calibration.

1 Like

will be at the shop today, will give this a go! :slight_smile:
it also sounds like… if I’m off for whatever reason, I can try tweaking $84 until it’s right…
thanks!

1 Like

still not getting it. I’m wondering if there’s a basic thing I’ve misinterpreted. .
at the following link is a google sheet (excel) with my values.
also a photo of the machine with tags and measurements.
link has ‘edit’ access to the sheet.
note: when the sled moves 500mm in X from center, sled raises 36.5mm in Y
Again, help is greatly appreciated.

you want the calibration chain length to be a multiple of 6.35mm so that you can
reset the chains to have a sprocket tooth at 12 o’clock

you need to motors to be as far out from the edge of the work area as you can
get them, so you want to move them to the ends of the beam.

note that the measurements to the motors are to the center of the motor shaft.

what are you using for your measurements? some tape measures are more accurate
than others, some cheap ones are off by quite a bit.

If you can use webcontrol, people get much more acurate calibration with the
holey clibration method.

David Lang

  • where should the sled be when the chain length is measured?
  • motors further out: yep familiar with this, figured after it’s oriented, should be easy to push the motors further out and update a couple of measurements.
  • motor center to center - yup, that’s how I measured. I think an earlier method had me measuring at 8 and 4 ocklock teeth on the motors.
  • tape measure seems to be okay, based on the 4’x8’ ply measurement.
  • webcontrol? I’m running a local makerverse app. and I can open the same interface on the web.
    is that what you are referring to?
  • otherwise, does it seem like I’ve measured the correct things? I think it thinks the center of the board where the sled is, is the ‘top’ of my space. it triggers a soft limit alarm when I try to move it up in the Y plane. This is why I think there is something off in how I’m measuring things. not that it’s an inch longer or shorter, but that I have the wrong measurement entered in some field.
  • where should the sled be when the chain length is measured?

is this webcontrol?

Makerverse functions by finding the center of your workspace and pressing reset chains. If you are at the soft limit, you likely need to disable the soft limit and reset the chains. Your y axis is at 519. If it really is at 519, it would be at the top of your work piece and the soft limit stops the sled from going up too high and destroying your ring. You can disable the soft limit by typing $20 =0 and then enter in the black window console on the left. Move the sled where it needs to be and then press reset chains and then reenable the soft limits ($20=1).

no, that is not webcontrol. That is makerverse. If you are using a due controller, that is the only choice you have for control software.

ok, I’m gonna mark this as ‘success’ as the Y creep during X travel from zero has gone away.
for reference: the issue was that it thought the sled was at position 500 (top) when it was at position zero (center).
but the ‘zero out Y’ commands were not working correctly and put the position at 350 for some reason.
solution was to go through calibration interface, skip to the chain calibration, measure from top of work area to the top of the sled, and that seems to have set it correctly to proper ‘zero’.
so, it seems to be moving correctly left/right/up/down so on to the next tests to make sure it’s accurate.
I’m guessing the Due is what maslow sends as the default controller.
is there an alternate recommended controller you can link me to?
will it wear the same motor controller hat this one does?

thanks. :slight_smile:

2 Likes

Congrats on success!!

With respect to the maslow controller you got from your supplier of choice, it will be ok to use it, it just helps to know which one you have. The due is the newer generation and only works with the newer makerverse software… the older mega works with the groundcontrol/webcontrol software and more recently makerverse. Each has their issues. I’d focus on getting what you havet working rather than trying to swap it.