You are disconnected - Keep getting this and then have to restart everything

Hi all,

Sorry for another post! Getting there with the setup but keep having this problem. I can get through the calibration but when I go back to the computer I get " You are disconnected - Connection lost for more than 20s".

It seems like the Maslow hasn’t saved any of the calibration data and then I have to do the whole calibration again. I’m in an endless loop!

I am right next to the machine and the router so I highly doubt it is a problem with connection. Could someone point me in the right direction?


1 Like

Try with a direct connection to the Maslow AP instead of connected over Wi-Fi network?

1 Like

Yeah good shout. Bit of a pain in the ass though so would appreciate it if anyone has any other solutions.

Also, do I really need to calibrate the machine every time I start up? It seems so at the moment and that means I need to manually take my belts off the bolts every time to extend them which takes ages.

Anyone got the same problem?

1 Like

You have to remount it to the frame, but you don’t have to calibrate.

Starting with Maslow off frame:
Retract All > Extend All > Attach Anchors* > Apply Tension

Starting with Maslow on frame:
Prepend the above steps with Give Slack** > Detach Anchors*

* Not a button. You do this with your hands, if it isn’t clear.

** I forget the actual text in the UI, but it’s the only button that looks like it would give slack

The Maslow doesn’t store it’s location across power cycles because it can’t trust that it didn’t move at all. There is an intent to make this experience better, but it is not a primary concern at this juncture because there are more-pressing items that need addressed. Some quick-and-dirty suggestions for avoiding a remount each power cycle have been suggested, it’s just a matter of if Bar or one of the other code-contributors decides to try implementing them.

Also, something like this makes this all much less annoying: Rehang-Helper Frame Mod

1 Like

Ah thanks for the advice. I wouldn’t have too much of a problem with the recalibration but the fact that I keep getting disconnected midway through calibration makes it impossible to use the machine at the moment. Don’t suppose you or @bar have any solutions for this. I normally just finish the calibration (sometimes mid way through) and I get a message telling me that I’m disconnected.

And when that happens, I need to remount the whole thing and recalibrate normally. I’m sort of stuck in a loop hahah!

Appreciate all the help!

1 Like

If you have completed a calibration and it says you have good values, you should be able to just remount it and hit apply tension instead of calibrate.

You might also be able to get away with just refreshing the browser window or reconnecting to the maslow wifi without powering it off, depending.

I can only recommend using the direct connection to the Maslow’s wifi instead of using an existing network and using the most powerful computer you can easily get out to your shop space for the calibration so it does the calculations faster. I stepped up from my relatively weak workshop laptop to my work laptop with a quadro in it to do the calibration and it calculated fitness much faster.

1 Like

Just realised I haven’t even managed to get a full calibration done yet. Only got to point 50 before it disconnecting. Then if I try and reconnect it seems to lose all data. Have switched over to directly connecting to the Maslow but am still having the same issue.

Hard to say if it is firmware or hardware really

1 Like

What type of compute device are you using when doing calibration? I’ve found I need to use my laptop because the calculations are fairly compute intensive. When I tried to use a wimpy tablet during calibration it struggled with computing the fitness in a timely manner. If the compute takes a long time for you, it could be worth trying something faster. The tablet seems fine when running jobs, though.

1 Like

We did change how that bit of code works recently so it’s possible that this is a new bug.

We added an option to turn that off in yesterday’s firmware update. If you update you will have the option to turn off connection monitoring here:

It’s possible that the calibration process is using so much computing power that your computer isn’t seeing the status messages from the machine.

That’s good feedback, we might have to do some thinking on how we want that system to work.

Thanks for suggestion. I was having the same issue and that solved the problem.

1 Like

Yes, I think there are “critical sections” (calibration, uploading/downloading, maybe more) where we should just turn off the monitoring during them. It is valuable to have it on in general, but there are certainly cases we should probably turn it off.

1 Like