Z-axis calibration doesnt work

I can fiddle around with the scaling but the “define zero” button never appears. So I can’t set zero, and the ,machine doesn’t actually know where zero is. When I try to do Precision, the machine tries to drive the router all the way down through the sled unless I ( once again ) pull the power during a calibration step .

Makermade says to skip that step because it is already calibrated but it sure doesn’t seem that way to me.

Z is something you have to set with every bit change. I don’t know the makermade
software, but in groundcontrol and webcontrol there is a Z axis menu that lets
you run it up and down and set zero (and trigger the auto-probe if you are
equipped for it)

David Lang

1 Like

yep, that’s part of the step that Makermade has told me to skip. How could the machine possible know where zero is? the router, the bit, the placement of the router in the clamp, placement of the bit in the router , all variables. i don’t know how you can skip the “define zero” step, and for Makervwrae it has to be done before the precision calibration because that involves cutting holes.

1 Like

This sounds like your z axis pitch setting is way off. What setup are you running? M2 or custom z axis?

The higher the number the shorter the distance the z with travel. The +/- depends on the position of the motor. If it’s an M2 Makermade should be able to tell you the pitch. I’m not keen on Makerverse and don’t know is the correct pitch is input by default.

1 Like

To calculate the movement error:

E = D2 / D1


E = Error

D2 = Distance the carriage actually moved D

1 = Distance the carriage was requested to move

To calculate the corrected setting:

C = Z * E


C = Corrected Z-Axis mm/rev

Z = Z-Axis mm/rev from the test

E = Error

*Taken from the meticulous z axis instructions

This is a Maslow M2 running Makerverse. z-axis pitch isn’t a setting.

this isn’t an issue of calculating how the pitch is off, it seems to me an issue of the Makerverse calibration process being at best a work in progress and the instructions being given not aligning with reality. Thank you for sending this math but if that is the process forward, it’s going back in the box. I don’t have time for that kind of wrangling . But thank you, it is appreciated.

Don’t give up just yet. I’m pretty sure there is a pitch setting Makerverse. I’m sure someone will comment that uses that software. @MakerMadeCNC

1 Like

you use the shuttle box over on the right to zero the z axis. Move it up or down until you get to where it is even with the bottom of the sled and then press the zero button:
If my memory is off, then use the three dots just to the right and it should be in that context menu that pops up.

I made a video on how to use makerverse to calibrate the M2 style system that may be useful and I am pretty sure this is in there.

1 Like

thank you @Orob thats exactly what I needed, why didn’t I think of that?


Probably the same reason I didn’t either the first few times I tried. It isn’t intuitive even for those who are masters of the obvious. But it is there.

1 Like