Maslow Home Maslow Community Garden Newsletter

Z-Axis Resolution default setting

Trying to calibrate and all of sudden my Z axis went bonkers and was traveling forever when I asked for 1 mm. Looking at things I see a wonky setting for Z-Axis Resolution=192195.01 steps/mm which doesn’t look right at all.

I downloaded the Makerverse code but don’t see anywhere a default value is used. What should it be?

This is a new M2 assembly and my first try at using CNC but no stranger to firmware.

I think you mean parameter $102. At some point in time (days after my initial calibration), $102 changed on me from its default of 472.5 steps / mm to :

“$102”: {
“name”: “$102”,
“value”: “918.750”,
“message”: “Z-axis travel resolution”,
“description”: “Z-axis travel resolution in steps per millimeter.”,
“units”: “step/mm”
},

Still a very different value than yours but hopefully this helps you.

How do you get those values? If I enter $$ all I get is 2 ok’s.

reset chains should be done before you calibrate especially if your system is running crazy. The maslow after being programmed does not know where it is and if you don’t reset the chains, it will go until it thinks it is home and it can wreck itself. hit that and then try again.

I entered “$102=472.5” (without the quotes) to set the value. It was possible to check the current value via the settings. If you’re having problems finding it let me know and I’ll make some screenshots.