Maslow Home Maslow Community Garden Newsletter

Z axis not physically at depth before sled moves

Anyone else have an issue with the z axis using the m2 and makerverse 1.1.2 …when I was calibrating I would have to set the depth of cut to .5 in order to cut .1…yes I did zero that axis and yes the pitch is correct If I tell that axis to lower(not in calibration) by .1 it does perfectly with no issues. I’m thinking it has to do with g-code line executing before the Z axis is physically at the depth almost like encoder values are updating in makerverse so it thinks that it’s at its depth. Any help much appreciated

This is absolutely a possibility. You can set the plunge rate when generating the gcode to limit that issue. Trying a lower speed could tell us if that is what is happening.

I’d like to see the first few gcode lines, wonder if the CAM software combined the first Z move with one in X and or Y (ramping in) or if the plunge is done separately. Something like G1 X1 Y1 Z1 rather than G1 Z1 then G1 X1 Y1.

1 Like

This happened during calibration as well so it’s not programmed g-code related I think it has something to do with settings in makerverse ? If thats possible

1 Like

I will try this… thank you

Executing two separate moves together would be serious breakage in the M2’s gcode firmware, which is why I was curious about the actual instructions being sent.

their calibration procedure I would think would send the correct g-code to the due. in the precision calibration tab I call for a .1 cut but by the time the bit lowers it seems the command to raise is already executed and the bit raises without reaching the .1 that’s why I call .5 to give the bit more time to make a cut. If I lower the bit manually I have no issues and the z axis goes the correct depth every time. thank you for your time I apricate it

I’m still a little confused about exactly what is happening? Any chance we could talk you into posting some pictures?

ok ill take some when I get home. ill try and explain a little better. during the precision procedure whenever the sled moves to any location it starts to lower to make a cut(target distance set at 1 inch and depth .1). the bit only lowers around .05 before retracting and then waiting until I select around location to cut(small squares around the edges for calibration) so I would have to set the depth of cut to like .3 or .4 in order to make a small hole in the waste board so I can calibrate(actual cut maybe .1). In the z-axis tab when I check to see if my z axis is correct its perfect I ask for .25 I get .25 I ask for 1 inch I get 1 inch(using a micrometer) thanks for your help

When controlling z axis using makerverse should the z axis move the same time the encoder feedback updates …the screen seems to reach set depth way before I physically reach it ive changed out the motor and cable but no luck

I should mention I bought classic first and then Bought the due board for the upgrade but using the original motors not sure if that matters

I’ve noticed that too. If you unplug the motor power to the arduino, but not the usb, tell it to move, the display will show it moves and then if you plug it in it will move to catch up… But has no check if it is behind. The older board firmware had an error it would throw if it didn’t move and would alert you.

Yeah would throw sled not keeping up correct ??? What do you think this fix is going to be

Thank you everyone for your input I lowered the max feed rate for the z axis from 250 to 40 and that solved it !!

1 Like

What is your z axis max feed rate set at ?

So with a feed rate too high, the system didn’t wait long enough for the physical movement? Very Interesting. This would depend on the max motor speed and your belt pulley ratio. My max feed rate on my mega system is
$18 (max z rpm) = 100 (default is 12.6 on the mega
$112 (z axis maximum rate) = 1500 (default is 250 for std z axis motor, I have 100 rpm metal motor on my sled). I also have different PID values and step settings for that motor that I configured, so it probably isn’t apples to apples for your system if you have an M2 controller with a classic system since we have different motors. According to my notes (which could be incorrect because my z axis motor is different), the default max speed for x and y are 25 while the default max for the z axis is 250. I don’t know why these values were chosen, but here they are:

mega firmware in settings.cpp line 83

sysSettings.maxZRPM = 12.60; // float maxZRPM;

due firmware in defaults.h line 44

#define DEFAULT_Z_MAX_RATE 250.0 // mm/min

It is important to note that the mm/min depends on your drive system to convert to max z rpm, so these numbers will rarely if ever be the same. It is good to know that your system will work better if it slows down. Where did you buy your classic kit?

I bought the classic from maker made then been slowly adding upgrades one of those upgrades was the board I did not use their Z axis set up Uploading: image.jpg…

1 Like

I’m a proponent of flipping the motor and using a belt drive for 3x faster movement in addition to your increase. Your build looks great is probably close to 3x faster than stock as it is. Very nice. What did you use for the center channel? I was looking at using a 3x1.5 (80/20 extruded aluminum) but cutting out part of the center diamond cross section for the lead screw. Not sure if that would be strong enough though. I have to make a z axis for my one machine that doesn’t have one yet and I’m trying to build it out of spare parts I have laying around. I have a 300 mm x8mm lead screw and some skateboard bearings and some 80/20…

Thanks !!! I’m switching over to the M2 sled bc this one is warped:( with .128 HDPE for the bottom of the sled ! …I do have a 122 RPM motor I’ll be switching for the z axis IMG_8772|video