Maslow Home Maslow Community Garden Newsletter

Z-axis raising but not lowering (not the motor - the code)

Hello, all.

I am trying my first automated z-axis cuts and am having issues. Using Fusion 360 and the MaslowCNC config, I generated a gcode file that takes roughdown steps of up to 3mm. However, when I run that gcode, my z-axis will not perform accordingly.

I would expect the Maslow to move to the position, lower the z-axis to the appropriate depth, make the cut, then raising itself to my “safe height” and move to another position to repeat the process. Instead, the Maslow moves to the position, raises the z-axis to the router’s maximum height, tries to make the cut (though the bit is nowhere near the piece), then repeats itself.

I have zero’ed my Z-axis accordingly and, when I hit any of the commands based on that zero, it does return to the proper height. However, when it comes to automation, that zero doesn’t seem to be taken into account at all. (Also, for reference, I am using the recommended Rigid router.)

Does anyone know why this could be the case or have any suggestions on how to change it? Thanks in advance!

I suspect it has to do with the coordinate system of Fusion 360. With respect to CNC machines, a negative z value is downward into the wood. Maybe Fusion 360 is using a positive z value. Can you post a bit of the gcode?

Thanks, madgrizzle. Here are the first 28 lines, which look like a pretty accurate representation of most of the file. I do see the Z-axis changing. I wonder if it’s just changing at such a small rate that I didn’t notice it. (And it does appear to be in the 30’s consistently. Though, from eyeballing it, I’d expect the Z-axis to be at over double that, when it fully retracts.) If the issue comes from something I’ve done in Fusion 360, how would I remedy this?

(While typing this, I had a thought… Let me make sure I understand zero’ing properly. I am supposed to take the bit and level it directly on top of my piece, right? So that a -5 would equate to a 5mm cut. In this instance, I could see these “30” numbers working as they should if zeroing is supposed to be going to the bottom of your cutting piece - however, that does go against my current understanding and could just be coincidence.)

(SIMPLE-GUITAR-TOP)
(T1 D=6.35 CR=0 - ZMIN=3.926 - FLAT END MILL)
G0 G40 G90 G17
G21

(2D POCKET9)
T1 M6
M3 S10000
G0 X-200.11 Y398.689
G0 Z43.1
G1 Z42.1 F1000.
G1 Z35.735
G1 Y398.681 Z35.636
G1 X-200.111 Y398.658 Z35.539
G1 Y398.62 Z35.447
G1 X-200.112 Y398.568 Z35.362
G1 X-200.114 Y398.503 Z35.286
G1 X-200.115 Y398.427 Z35.221
G1 X-200.116 Y398.342 Z35.169
G1 X-200.118 Y398.25 Z35.131
G1 X-200.12 Y398.153 Z35.108
G1 X-200.121 Y398.054 Z35.1
G1 X-200.122 Y398.029
G1 X-201.424 Y323.013
G3 X-201.105 Y322.656 I0.353 J-0.006
G3 X-195.04 Y322.179 I16.522 J171.148
G3 X-188.964 Y321.869 I18.693 J306.809
G1 X-186.068 Y321.75

Yeah, your gcode raises the z-axis. I’m sure someone around here ran into this problem before with fusion 360. I’m pretty sure there’s a setting for fusion 360 somewhere that would fix it.

1 Like

Are you using the f360 post processor for maslow:

https://forums.autodesk.com/t5/hsm-post-processor-ideas/a-fusion-360-post-processor-for-maslow-cnc/idc-p/7798893#M807

1 Like

Thanks so much. I’ll keep looking into it. Just knowing that it’s something with Fusion 360 is a good starting point.

I did use the Maslow Post Processor for Fusion - and mine took without any visible issues.

Have you considered to change the sign of your z-Axis pitch in G-code. Seems to me that should do the trick without having to change anything else. Obviously you would have to be careful if that inverts your commands for manually raising/lowering the bit.

If you can’t find the setting, then that suggestion would work. There are plenty of people here that use f360 but maybe not reading this thread. You could consider editing the title to better describe the issue.

Go into cam setup and check the “flip Z axis button”
screenshot1575598195@1X

1 Like

I’ve solved the issue, for anyone who may stumble upon this same problem in the future. The problem is that, with F360 (at least how my configuration is), I need to set Maslow’s Zero to bottom of the cutting piece. It’s not just a coincidence - it’s how Fusion 360 is set up. If you run simulations inside of Fusion and specifically watch the Z-axis height, you can see everything working properly, as the bit approaches “zero”.

Thanks for the help, everyone!

2 Likes