Maslow Home Maslow Community Garden Newsletter

Z axis scaling issue

I was calibrating before a project and when I tried to adjust the z axis scaling it kept giving crazy numbers like move 10mm was the command and it would go 38.86. I would type that number in box and on the next try it would be something like 3mm. I kept trying till the motor just slowed down and stopped moving, around 15 tries. I’m totally confused on why or how but would just like to get it back to operational. Thanks

makerverse 1.1.2
maker made m2 with due board

I was trying to calibrate my machine last night, and got the same issue. Now my z-axis doesn’t want to move even if I “wipe settings”. Any way to completely revert to the default values? It looks like some PID parameters got out of whack.

Original Arduino Mega with “blue smoke herder” shield.

it is possible you are the soft limit for the z?

Or maybe a loose connection to the x-axis encoder? If it’s getting flaky data back it might behave strangely

That was my first thought as I’ve had similar issues with the other motors in the past, but I’ve double and triple-checked the connections; even tried another cable.

I’ll look at the soft limits

1 Like

Perhaps see if your router is in the router holder too tight. I just remember that I had mine in too tight and the z-axis would move very inaccurately.

1 Like

I have a C-Beam Z-axis, and I actually don’t have a router in it yet! I’m waiting for a new spindle to show up (should be sometime next week). In any case, I tried with the motor completely detached from the machine and it still does the same.

@Allen_Bryan I managed to find it. Somehow, the setting named “Z axis Kp position” was set to 0. I reset it back to its default value of 1300, and now it’s moving normally. I haven’t checked the calibration, but at least it moves!

2 Likes

where did you find this setting, doesn’t seam to be on the front page?

In Makerverse, below the “calibration” buttton you have a “settings” area you can expand. It’s about halfway down the list in this.