Z axis stops reporting position on main ground control screen v1.20 - Happens again! -- Firmware Solution?

Thanks for the clues. For anyone else who may be wrestling with this I tried to export dxf from sketchup 15 and use it in online easel. It didn’t work. Kept playing with it and saw notes from some users in inventables that it needed to be joined. So I export to dxf from sketchup. Open up in CAmBam. Join whole dwg to 0.001. then export from cambam to dxf again(change file name for tracability). I can then import sketchup designed dxf into easel.

I will continue to evolve this because I think now that Cambam is generating gcode that upsets the maslow. Now I can design the 2D part, process in this way, and then run the gcode generated by easel in the maslow. Same part, but different generation of gcode.

Thanks again

Here is a thread in the forum that discussed getting SVG files from Sketchup to get them into Easel.

I think we are now cooking with gas!!

I ran test shapes thought easel to understand the setups - tabs, depth of cut, inside or outside, size of bit, etc.

I then took my part, made three parts from it - outline - holes - inside cutouts. I ran them through cambam to join and then export as dxf. i then imported the dxf’s into easel one by one, making sure all of the settings were correct, and then exported the generated gcode files.

As I suspected, the gcode was much different than the gcode that cambam generates. The were only G0 and G1 codes in the whole file. I previewed them with camotics and they viewed identically as the cambam generated ones.

This weekend I will run side by side tests to prove that the cambam generated gcode files are the problem, but I think I found the smoking gun.

Thanks for all your help. Hopefully this dialogue will be of help to users who start to make complex parts with the Maslow