Z Axis troubleshooting

Hi All,

Having some troubles with my M2 on win 10 makerverse 1.1.3.

After assembly the Z axis would not move, it appeared the top bearing “holder” had been compressed too much during assembly with the gearbox (Friday afternoon or Monday morning at the factory) I was able to massage it out and it started working.

Xavier was contacted and we thought the problem was solved.

Now it is not working again, I tested the motor with 12v and it works fine, so I connected the Z axis cable to the left drive motor port on the controlled and activated the left motor in the software and it worked fine and consequently connecting the left motor to the Z axis port resulted in no movement.

Any help at your late hour would be greatly appreciated, nearly midday here in Oz. (I guess Xavier has knocked off for the weekend)


assuming you have double checked that the Z axis is enabled in the settings, it
sounds like you have burned out the chip on the controller. It’s unusual for
that to happen on Z, but possible.

David Lang

Thanks for your reply David,

I assume the Z axis is enabled as it was working at some stage.


As for burning out the chip what would that chip be and is it replaceable?

It’s a software setting, so it could have been turned off. Check before you
replace hardware.

David Lang

they aren’t designed to be replacable. If you are good with desoldering chips
from your driver board you can do it. I’m not familiar with your controller, but
it’s probably the chip closest to where the Z axis plugs in.

David Lang

Just my luck it has fried. It will take a couple of weeks to get a new one from the states.

Well isn’t this interesting, I upgraded makerverse to 1.1.4 and guess what?
The Z axis is working again, why?
No don’t answer that, I don’t want to know why, I’m just glad it’s working.
Just as well I have a lot of hair.

haha, sorry, I don’t mean to laugh. I have lost a lot of hair stressing over other things and these machines do cause me a lot of hassle sometimes too.

I’m willing to bet that it was something in your configuration settings, and the new software reset them. These things really demand an incredible amount of patience and determination sometimes to figure out the issue and fix it.

Glad to hear you figured it out.

Now carve up some stuff and show off what you can do!


Thanks Jeremiad,

You are probably right, anyway it’s still working and I’m going through the calibration process now, no matter what I do with centering the router it still moves in a small arc when I rotate the sled.


1 Like

if it is moving in an arc, you need to shift the router so it is centered on the ring movement or shift the ring to be centered on the router shaft. so when you spin the sled, the mill stays true or you will have dimensional variance based on how the sled is positioned as it moves.