Maslow Home Maslow Community Garden Newsletter

Makerverse no z axis movement at all

I cannot zero the z-axis it will not move at all I cannot raise it cannot lower it the motors just make a humming noise and just sit there running the newest holey 51.28 or something like that firmware just have the regular motor on the z-axis like you would do with a rigid but I have the Ryobi router so that doesn’t matter at all. Everything worked before I switched over. And I switched to makerverse so I could have actual possible use of the outer edges of the stock. And my z-axis ran perfectly fine on GC now I go to makerverse and now the darn thing doesn’t work at all. My x and y-axis run perfectly fine. What do I need to do to get my z-axis to move cuz it’s not moving up or down at all. I have the mega 2560 board running Windows 10 connection through USB this is the newest maker verse that is supposedly backwards compatible with the older Maslow’s but I just ordered this thing through maker made a couple months ago. I mean literally the thing is sitting here and I’m losing money I had a landscaping company for 11 years until covid-19 came around and then I lost all my customers so now I run a custom woodworking business with my Maslow it’s not the fastest production thing in the world but it pays my bills. I just need to get my z-axis working again cuz that’s the only thing that is not working literally I pressed up or down on the z-axis through maker verse and everything is installed correctly to the best of my knowledge. Literally there is no movement of the z-axis at all all plugins I’ve unplugged and plugged them back in to see if that might correct my problem but nope no matter what I do I cannot get z-axis movement .

Are you saying it quit after installing new software? What happens if you go back to what you were using before?

the internal shaft on the motor was binding the gears up . i ordered a new one. im gonna put the inner parts(gears) in my ultrasonic cleaner , re grease the gears and go from there. will update later

1 Like

I have recently installed and tried to calibrate with Makerverse 1.1.2 and the z-axis quit working once in the app. It would actually move the sled down the first time I tried to move the z-axis…first movement only, then it would just make the hum sound and no movements. It was working just fine in Ground Control. I was getting a flag saying I needed Firmware 51.28, so I installed the latest firmware, no luck. So I tried a few different versions of the firmware, no luck. I installed Makerverse 1.0.6 and still no luck. When I go back to Ground Control I have full z-axis movements and have run another calibration and it was spot on. I would like to try Makerverse but not sure what is wrong.

did you trigger the softlimit?

where do you see soft limits? I’m in the the exact same situation as trojanowich.

here:


(for the M2 / Due controller). If you don’t see that, then you are not using 1.1.2, you have a mega, or something else isn’t quite right. the manual command to disable soft limitis is:

$20=0

to reenable them after you get things moved back within limits and zeroed:

$20=1

Caution: if you have soft limits disabled all the time, the sled can drive off the left, right, top, or bottom of the spoil board and the z axis has no limits, so self-assured destruction is a possibility. Please be careful.

I have a first gen maslow with the Arduino Mega. The only way I could figure out to send a command like $20=0 to the Arduino was to make a custom button. Seems to have worked as I got an OK back (screen shots).

with the limits off ($20=0), I still get humming with no movement.


ok. I’m sorry. The soft limits do not apply to the mega gen 1 systems, which is why it is not shown in your settings list. I reread your first post and 51.28 is the mega. Makerverse 1.1.2 is the only version that works with both the mega and the due. 1.0.6 was made for the Due, which is why it did not work. Sounds like your z axis setting is incorrect. In the calibration, you can adjust the movement numbers for the z axis. You may need to adjust those. I’ve not done a full calibration for the mega in makerverse, only the Due. I had planned to, but I have the metal maslow with the different z motor and have not yet tuned it with a mega, so the best i can do is point you in that direction and hope you figure it out.

On this screen when I click move up or move down the whole sled moves down, in the Y axis. So what is my next step?

have you tried the wipe settings button in the lower left to start with? If the wrong motors are moving, is the shield plugged in completely and the motors connected to the outer plugs M1 and M3 with the z axis connected to M2?

regarding everything pluged in. I just verified, but everything was working before on groundcontrol. now on makerverse z axis not working. everytime I try to move the Z axis i get an alarm:3

double checked all connections
opened calibration screen
clicked wipe settings
Maslow “rebooted”
opened calibration screen
stepped through calibration to z axis
clicked up, Z moved down (something new), y moved down
put in negative scaling
clicked apply scalling
clicked up, Z moved down, Y moved down
unmounted Z motor, as system was about to crash did not change electrical connections
clicked up, Z moved down, y moved down
clicked down, Z moved down, y moved down
clicked up, Z moved down, y moved down
clicked wipe settings
maslow “rebooted”
open calibration screen …all same as before…

For anyone following, Orob and I have been working one on one, and have gotten makerverse working with the latest firmware (Newer than Holey 51.28), compiled from source.

Success, downloaded the source, from https://github.com/WebControlCNC/Firmware/archive/master.zip opened in Arduino IDE export compiled binary and transferred HEX file to Arduino in WebControl. I had to re-enable the Z-axis. Everything worked well in WebControl. I then switched back to Makerverse on RPi and everything worked well.

2 Likes

Makerverse is now working with my original Maslow.

2 Likes