Maslow Home Maslow Community Garden Newsletter

Problem with Z axis

Hello
I have a problem with my Maslow. I wanted to calibrate it again because the central point was a bit shifted. I did everything according to the instructions but when I went to the last calibration point (“drawing” my working field", my router did not make delicate cuts and instead it went right through my wooden plank. In the central part of the plank it actually managed to break through to the nut. Let me just add that I have an automatic z axis on the corners.
So, I immediately wanted to move the router up, but after a short whole it went back down again. Now it goes up and down every few minutes. Of course I unplugged the router itself. The z axis fires up automatically when starting the computer - it turns on for a moment when Adurio is loading.
Could you please help me to solve this problem?
Is it a software issue?

1 Like

Welcome to the Forum @PatMaster95!
Lets find out first what Maslow, z-axis, Aduino (Mega or Due), what motor-shield, what firmware is loaded and what software is used. From what you describe it sounds more like a loose plug or interference in the cable, but without any info, guessing does not get us far :wink:

Kind regards, Gero

This has my bet

I have this maslow http://maslowcommunitygarden.org/Maslow-kits-Pre-Order-.html
Firmware- master 2019
Z axis dc12v 201903025
Anduino Duo
Ground Control1.26

I am surprised, I think it does not work to load the Maslow firmware onto a

Did attempt to load the Maslow firmware onto it?

Is this a kit from Makermade? Then it should have come with a USB drive with the software.
The correct firmware should already be loaded to the Due. Grundcontrol will not run either way.

So what do I have to do, it suddenly happened and with the experience itself, the z axis starts working, I did not install any other drivers, only adurio and groundcontrol, please tell me what i must to do

~~ Not answered yet~~ sorry, was answered, however, the link you poted mentions a Mega, not a Due.
If you have the Due Arduino, the chances are good the the Firmware is on it. The software to use is Makerverse. Did any USB come with the kit? The software should be on it. I’ll search for a download link in the meantime. If @MakerMadeCNC in online, it’s a better source for help.

Yes i have USB, but tell me what program or firmware i must instal

Is makerverse on the USB?

Wen i return to home i check, and what i must to do? Reinstal adurio?

Your arduino should be ok. It was preinstalled. You need to get the correct program to talk to the arduino that runs on your pc. That program is called Makerverse and should be included on your USB that came with the package. Install makerverse and then connect to the arduino.

Heres the link for Makerverse.

Gentlemen, I downloaded a newer version of arduino and installed the makerverse and what next? All the time the z axis is on and goes down or up, it turns off only for a while as it is connecting to the arduino

is your z axis plugged in all the way? Is it plugged in to the correct location?

Makerverse setup video.

Gentlemen, I checked one more thing, I switched the cables between the x, y, z axes and whenever I connected any cable to the axis controller, the engine started immediately, so it is definitely not a problem with the cable. now I don’t know if it is a problem with the control system or the z axis motor?

So you are seeing this with the Arduino Due and the Makerverse software?

after starting the computer, I turn on the Arduino program and Maslow connects to it, then when I start the Makerverse, a window appears to me as in the attached photos. However, if I start the Makerverse first, the same window appears to me, but then I can not connect to the Arduino, of course, the motor from the z axis is rotating all the time

![118428435_1273471859663610_5031262731437740140_n|375x500]

The Arduino program is only needed to upload firmware and not needed in your case. It should be closed when you start Makerverse.
I don’t have the hardware to test and run it, @MakerMadeCNC will be of much more help here.
From the video link I posted above the screen has “Enable hardware flow control” turned off. In your screenshot it is on.


Your console shows strange symbols, the baudrate is correct, so closing the Aduino software might get some clear messages.

Definitely close the Arduino software. When it is open, it will fight Makerverse for the connection to the board. If you continue to see the garbled text, please email chris@makermadecnc.com so we can schedule a zoom call to go over your machine settings.

-Chris

1 Like