Maslow Home Maslow Community Garden Newsletter

Z motor fails during testing motors

We keep getting an alarm notification while we’re trying to finish calibrating that says that the sled is not keeping up with its expected position and we’ve tried to see what the problem is by testing the motors but we don’t understand what it means when it says that the z motor failed in both directions.

Is your z motor plugged in? You could try unplugging and replugging both ends of the cable, sometimes it can come apart enough to cause errors…

This error can also be caused by one of the machine measurements being incorrect so it might be worth double checking those

What specifically is a z motor haha. We don’t really know what we’re doing.

If you have a z axis motor, it goes on your sled and attaches to your router to raise and lower it automatically. It plugs into the MP2 port on your shield. If you do not have that motor, then you will have to do manual Z operations, by manually setting the depth of cut on your router.

I’m not sure if It’s normal for it to fail if that motor is not present, maybe @bar can chime in.

While setting up my new (very rough) Meticulous Z-axis, I had an issue with binding in the Z-axis, and now my z-axis is failing. Have I burned up my shield? If so, is the Due my best default option for replacement?

The Aduino Mega is the ‘brains’ for the Maslow and is the common standard.
The Arduino Due is a faster option with some advantages, but is in early development and not recommended, unless you are serious about getting into bug reports and beta testing. Not for the faint-hearted.
The Motor-Shield sits on top of the brains and can be used with either. Wow long do you think the motor was running blocked? It would roughly take a few minutes to burn the chip on the shield with a motor at stall.
With the power of the motor, it would likely try to break something mechanical, before overheating the chip, but we’ve seen chips unsolder themself because of a chain wrapped around the sprocket and blocking the motor.

Sure you have re-plugged everything and also checked GC that the setting ''z-installed" did not go back to “no-Z”. With a multimeter a faulty chip can be recognized by comparing the ‘ohm’ between 2 legs with the same legs on the other chip. This is how i found the that i’ve fried my left motor chip. The Z died shortly after, as they both sit on the same chip.

Kind regards, Gero

2 Likes

Perfect troubleshooting info. Thank you.

As a side note, nuggets like this evolve from forum discussion into “fact” (seems to be a loaded word these days), at which point it seems like it would serve Maslow users better by migrating into a wiki - maybe in GitHub. I know we have wiki functionality in Discourse, but it seems less than optimal. It would be useful to perform a search with the “facts” wiki only.

As a relatively new user, I often go on search-led wild goose chases trying to determine “what is the latest , best convention wisdom answer for my question?”.

Although I work for a PCBA startup, I’m not the EE, so bear with me.

I assume you mean the “L298P” chips, and any two matching leg pairs will do. I keep the board plugged in?

I set the multimeter on the Ohm setting. Mine has multiple settings - Ohm, continuity, polarity, nF and another Ohm with “auto ranging”. The pure Ohm setting gives me similar readings initially which then “run out” to zero.

Ok…so maybe I was supposed to unplug first.

I had the board out when i measured the chip. The multimeter has a diode symbol for measuring ‘pass’.
On a diode or a healthy chip it will show ~0.6xx in pass direction and 0 in blocked direction. A fried chip is completely shorted mostly, rarely just down to ~0.2 and identifies that the chip is dead. No 2 leg on the chip should give the ‘beep’. Unless it has 2 connected internally, don’t have L298P circuit on hand to check.

This are the 2 pins shorted (my left motor stopped working). Z died shortly after, but did not bother to check what pins that were.

1 Like

New board arrived and installed. Test Fails Left motor direction 1 and both Z. Any ideas?

Rebooted. Now Left passes, but Z still fails. What is the possibility that I have an issue with my Z motor?

Did you reuse an existing motor? Did you buy a new set up from Amazon? Try swapping the left and z motors - does the issue follow the motor? Do you have an old Z motor to test with?

Thank you

Thank you. It would appear that my Z-motor is the issue. It was my existing original kit Z motor.

If you can manually make Z adjustments or a way to, you can turn the Z off in the configuration and the software will stop and prompt you to make a depth change until you can get a replacement motor.

Thank you

I have replaced my Z motor. When I run the test, the Z motor seems to work fine, but Ground Control says it fails?

GroundControl and the Firmware care about which direction the motor turns. Try swapping the white and yellow wires - the stock Maslow uses white for Sensor A and yellow for Sensor B, many other motors reverse those colors.

That did the trick. Thank you!

It’s not pretty, but it works.

1 Like

Be very careful - the 5V pin is right next to one of the motor leads, and shorting those together will fry the Mega. Voice of experience…

3 Likes