Maslow Home Maslow Community Garden Newsletter

1.26 calibration left motor not moving / sled not keeping up issue!

Hey there, first forum post!

just got my frame built and hardware attached, I’m running GC 1.26 and firmware 1.26
I’m currently having problems beginning my first calibration, in both the calibration and chain length calibration menu’s i cannot move the left motor counter clockwise, it doesn’t make a sound or even try, just pops up with alarm notification, sled not keeping up. i read you can turn off the alarm but id rather sort out the issue and i cant seem to find that function on the new GC anyways. I first noticed the problem on my first attempt after i had the chain stretched over to the right motor and couldn’t retract or tighten and measure, the buttons simply didn’t do anything, no alarm. i reinstalled GC and tried it again, now its alarming. any advice?

update: tried restarting GC and re-connecting, finally let me run a motor test, all motors passed except the left motor counter clock wise. switched ports 1 and 3 on the arduino and the problem switched to the right motor. so ive narrowed the problem down to port 3 on the arduino

I wonder if the chip fried on the shield. I’m using Web Control rather than ground control, and you have to manually measure the distance with a tape measure, as the chain retract is rather rough.
Edit: oh, I reread the post you never ran the retract? Still must be the shield board if the problem switched to the other motor when you swapped cables. I don’t use ground control, but I think you can manually enter the measurement somewhere, rather than doing the retract, less chance of harming the board if you end up buying a new one.

so you think I’m looking at a new arduino? that something is fried within the board? all the pins look straight and clean on port 3, not sure exactly which of the wires controls CCW function

The board that sits on top, the Maslow Shield, I call it a motor driver board. It has the cooling fins on each of the two chips.
Did that motor ever turn CCW? I assume no pins are offset where it is plugged into the arduino. No bad solder joints? Most of the pics I’ve seen where they are bad, the chips are literally blown off the board. So the arduino itself is usually fine, but the chips on the board are smoked. Was it a recent purchase, perhaps contact the vendor? Those boards cost a bit.

Edit to show pic marked “3” of motor controller (driver, shield interchangeable terms). It plugs in on top of Arduino, but is a separate board.

my board came assembled with the heat sinks attached so i wasn’t aware the two came apart, i will inspect the boards thoroughly. i bought the maslow from makermade so I might try contacting them. i bought it around Christmas and finally crossed off enough other projects to dive into this. hoping someone chimes in with a software fix but it seems to me to be hardware :frowning:

Post a bunch of pictures of the motor controller/arduino setup. Maybe we can spot something wrong, but it does sound like a motor controller board issue. I doubt it’s software related. On that board, there are three pins per motor that control the movement. If one of those pins isn’t soldered/inserted correctly or there’s a cut trace or something on the board, I think you might see such behavior.

let me know if you need anything else to get a good look, really appreciate it!

Nothing readily jumps out. I assume on that last image, the left middle row of pins is fine and reality and that’s just reflection/glare that we see. I’d contact makermade and ask them about it. Seems hardware related.

1 Like

The power supply can cause weird behavior like this sometimes, but it’s usually the controller board.