Z axis calibration problem and I keep getting the alarm that sled is not keeping up

As the title says I keep getting an alarm for the sled is not keeping up I made sure to turn down the speed to below 500 mm a min vs the 30 inchs a min I was doing then I. Go to recalibrate everything and I get to the z axis calibration and it won’t go down it won’t go up nothing I go and hit the test the motors and encoders button and everything works fine that’s when I didn’t know what else to do but to come here.

Hi Wyatt!

Regarding the sled not keeping up, which version of Ground Control are you running? An earlier version had a bug, and the Position Error Limit needed to be raised. I am currently running v 1.18, and it runs fine with the setting at 200 (in “Advanced Settings” all the way at the bottom).

Regarding the Z axis not moving, several things to check…

First, be sure the motor lock on the router shell is not too tight. Open the lock so the router motor is really loose in the shell and see if the Z axis works. If so, then adjust the lock to minimize the slop, while still allowing movement. Also, polish and lubricate both the motor case and the inside of the shell. Close inspection is a good idea here, as you need to maximize smooth movement. My sleeve had a small warp in the channel that the alignment pin on the motor runs through, and needed some filing.

If the motor is turning the screw gear, but the router is not engaged and moving, move the router up and down in the shell to ensure that it is engaged to the linkage that connects to the screw. Note that there is a plastic part in the linkage that is designed to break if the router is stuck in the sleeve while the screw gear is turning. This protects the mechanism from permanent damage. If you ran the Z axis with the router locked, or ran the router past the up or down limits, this part may be damaged and needs to be replaced…

Good luck!

1 Like

Hi there, I kept receiving this message to and solved it by raising from 2.0 (default) To 20.

What bugs me is that my machine keeps losing USB connection and every time this happens, I have to recalibrate. Any hints what could be happening?

Hey sorry for the slow reply nothing is broken on the router the z axis won’t go even if the router isn’t in there. But again if I hit the stop button and go hit the test motors and encoders button to make sure everything is still working and everything works just fine, even the z axis works fine if it has the router in it so again I’m kinda just scraching my head here…:disappointed_relieved: I’m running version 1.2

Be sure to turn off all energy saving features on your computer. When it goes to sleep, the USB port is turned off, which causes mayhem with the Maslow.

Hope this solves the problem.

How would fix that issue because that has happened to me I just went and unplugged everything replugged it and restarted everything and it worked fine could this be what is causing the problem now?

After you reset everything, it is all working now? If so, maybe a power surge, static discharge, or other computer realated event ocurred. Be sure your electricity supply is solid.

Thanks for the tip, will try. Together with a better USB cable. If both work, I will not know which was the culprit, but I realli do not care…

Any thought how to speed up, or avoid re- calibration process??? LOL

The Maslow experience is one of constant growth, or frustration, depending on whether your glass is half full or half empty. I am just another grasshopper. This Forum is pretty good therapy, especially when you see what others are doing.

I thought it was working I managed to finish my cut but like I said I unplugged all the cords in the maslow and the Arduino. Then I went and clear the g code in ground control and exited out then reoped it and the file. Everything worked untill I went to do another cut same day and everything now this. I’m starting to wonder if I should wipe the eeprom? If that would help and just restart everything…

Glad to inform: rearranging the setup, with shorter USB cables and power for the router and duster to one side, computer to the other, did the trick!


Also when I look at the command window it glitches out and keeps saying (index error when reading gcode) I do not know if that means anything to anyone the z axis has a crazy high number on it now

… I’m just trying to provide as much info as possible ohh and does anyone think wiping the eeprom? will work assume that does what I think it does and I have to re download the firmware on to the Arduino and all that happy fun stuff
… Any comments would be welcome and I can not thank you guys enough for being so patient with me.

Wiping the EEPROM doesn’t remove the firmware, it removes stored values from calibration. You’ll have to do the Automatic Chain Calibration again to measure out the chains, but I’m pretty sure your other calibration values will come across from GC.

But will that fix the issue that I’m having

I’ve never seen the ‘index error when reading gcode’ message, not sure where that might come from. @oliverilg found that moving his laptop’s power plug to a different circuit from the router and joust collector helped in his case, that’s something you could try. Routing the USB cable so it doesn’t pass near the power cords for the router or dustcollector would be a good thing to try. Make sure that the USB cable is well seated , if there is a USB hub between the laptop and the Maslow make sure that it has its own power supply, and not on the same circuit as the router and dust collector. Those are all things to try.

I have tried unplugging everything except the Maslow no router, no laptop plugged into the wall nothing but the maslow plugged into the wall. I know the circuit is good I have use many other power tools on it today alone. So again laptop on battery power and nothing but the maslow plugged into the wall and still nothing​:persevere::disappointed_relieved:. Same problem z axis won’t calibrate the motor just won’t move and it has a crazy high number. It won’t run any file and I can’t use the home button both will result in a (sled not keeping up notification). I can move the sled with the arrows and the test motors and encoders with everything passes so I know the motors are fine… I just had it working to…

I think that you are right that the crazy lage number in the z-axis setting is the issue. Have you tried resting the z-axis to be zero?

1 Like

One moment good sir


Is there any way I can :kissing_heart: you ohh thank you my dude it is working perfectly


WOOOOOOOO!!! Best possible answer :grinning: Glad to hear it :tada: