Maslow Home Maslow Community Garden Newsletter

Alarm:2 (Soft Limit)

I’m moving from the original Maslow setup to an M2 from MakerMade, using Makerverse 1.0.6. I’ve run through the Workspace setup, Machine Settings and scaling setup (haven’t done an actual cut yet to confirm), but when I try to jog any axis I get no response from any of the three motors.

All three are making noise, so they should be connected, and I have reseated all the wiring to confirm it’s in there firmly. I have clicked Unlock, and Set Home but still nothing.

When I attempt to jog any axis the command window shows the correct G-code command but after trying to execute it I get the error ALARM:2 (Soft Limit) [MSG:Reset to Continue]. I searched the forums for the error and couldn’t find much. I’ve tried resetting but still get the same result. It’s acting as if some setting in the X,Y and Z axis isn’t set correctly, but I can’t find which it might be. Any help would be appreciated.

search for this problem on the grbl forums/lists.

David Lang

I encountered this. If you click the settings widget and scroll to the bottom the x/y/z soft limits are shown as

$130 x max travel
$131 y max travel
$132 z max travel

these are + and - values.

if you want to override them, disable soft limits by typing the following in the black - backed terminal:

$20 = 0

there is a setting for soft limits you chan change and save, but I can’t screenshot it right now. You’ll have to look around for it in the settings widget below the terminal widget on the left side of makerverse if using 1.1.2. If using 1.0.6, then just type it in.
when finished, reenable the soft limits

$20=1

1 Like

Ok, but what are the soft limits supposed to be? I had thought these values were supposed to be already present for the M2 in Makerverse. I’ve tried simply turning off the limits using $20=0 and jogging the axis and still have no movement. Just like before, though the controller seems to be registering the commands, it’s just no longer throwing the Error ALARM:2 (Soft Limit). The Machine Position/Work Position on the right is also not updating.

According to the console presently:
$130 = 2500.000
$131=1250.000
$132=25.000

Soft limits keep the sled and z axis from going out of bounds… If they were set correctly to begin with. I made a video for calibrating and my z axis was too high and I hit the z axis soft limit just trying to zero it. Turn it off, zero it, turn it back on. When set, they can prevent bad things from happening.

There is definitely something off with the 1.0.6 version of Makerverse I downloaded. I’m running through the 1.1.2 version and not having any issues.

1 Like

Now I’m receiving the soft limits error
ALARM:2 (Soft limit)
[MSG:Reset to continue]
I’m running the same G-code I was running a week ago, now I’m getting soft limit errors
I did wipe everything and start anew trying to get this damn thing calibrated
Does anyone have a flame thrower?
I would set the entire rig on fire, but it is in my driveway. My neighbors might complain

I’ve had issues with soft limits for the z axis with the M2. it makes sense to have it for X and Y, but not for Z because it is only an inch. You can turn it off, move the z axis and zero it, then turn soft limits back on.

Orob,
Thanks a bunch.
Very helpful information

1 Like

or you can just make the z limit very very large…